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Abstract
The BehavePlus fire modeling system is a computer program that is based on mathematical mod-
els that describe wildland fire behavior and effects and the fire environment. It is a flexible system 
that produces tables, graphs, and simple diagrams. It can be used for a host of fire management 
applications, including projecting the behavior of an ongoing fire, planning prescribed fire, assess-
ing fuel hazard, and training. This report documents the BehavePlus design and features to help 
users better understand the system and use it more effectively. It is based in part on material in a 
series of self-study lessons that were developed to provide a detailed, step-by-step description of 
various aspects of BehavePlus. This report supplements two reference guides on BehavePlus: a 
User’s Guide describes operation of the program and can be accessed at http://www.fs.fed.us/rm/
pubs/rmrs_gtr106.html, and a Variables paper describes the more than 180 variables in Behave-
Plus and can be accessed at http://www.fs.fed.us/rm/pubs/rmrs_gtr213.html. 

Authors
Faith Ann Heinsch is a Post-Doctoral Research Ecologist with the Fire, Fuel, and Smoke Science 
Program at the Fire Sciences Laboratory in Missoula, Montana. From 2002 to 2008, she worked at the 
University of Montana with NTSG in the College of Forestry and Conservation, where she analyzed 
vegetation productivity in response to current changes in climate and collaborated on climate change 
research, education, and outreach. Her research focus is on fire behavior prediction and fire danger rating.

Patricia L. Andrews is a Research Physical Scientist with the Fire, Fuel, and Smoke Science Program 
at the Fire Sciences Laboratory in Missoula, Montana. She has been at the Fire Lab since 1973, 
serving as Project Leader of the Fire Behavior Research Work Unit from 1991 to 1996. Her research 
focus is fire behavior prediction and fire danger rating.

Acknowledgments
Coding of BehavePlus was done by Collin D. Bevins, on contract with Systems for Environmental 
Management (SEM). BehavePlus was designed by Patricia L. Andrews and Collin D. Bevins. Fund-
ing was provided by the U.S. Department of Agriculture, Forest Service, Rocky Mountain Research 
Station; U.S. Forest Service, Fire and Aviation Management, Washington, DC; and the Joint Fire 
Science Program.

BehavePlus is supported by U.S. Forest Service, Fire and Aviation Management, Fire Applications 
Help Desk (Phone: 800-253-5559 or 208-387-5290; E-mail: fire_help@fs.fed.us).

We thank Warren Appelhans (U.S. Forest Service), Larry Bradshaw (U.S. Forest  Service), Joe 
Scott (Pyrologix), Deb Tirmenstein (Systems for Environmental Management), and Robert 
Ziel (Michigan Department of Natural Resources) for providing helpful review  comments on 
this document. 

You may order additional copies of this publication by sending your 
 mailing information in label form through one of the following 
media. Please specify the publication title and number.

Publishing Services
 Telephone (970) 498-1392
 FAX (970) 498-1122
 E-mail rschneider@fs.fed.us
 Web site http://www.fs.fed.us/rmrs
 Mailing Address Publications Distribution 
  Rocky Mountain Research Station
  240 West Prospect Road
  Fort Collins, CO 80526



Preface
The BehavePlus fire modeling system, Version 5.0 began as a DOS program for fire behavior 
prediction in the 1970s. The original BEHAVE was later combined with fuel modeling programs to 
make it the BEHAVE fire behavior prediction and fuel modeling system. When computers devel-
oped to the point that it was possible, BEHAVE was made available in the field in 1984. A major 
update began in 1999 with a complete redesign and a change from FORTRAN to C. BehavePlus, 
Version 1.0 was released in 2001. Modeling capabilities and features have been added with each 
version. 

Some of the design described in this report is based on decisions made more than 10 years ago. 
We recognize that there are deficiencies, but we also know that BehavePlus is a successful sys-
tem and, in most ways, is a useful tool for fire managers. Hopefully, there will be a next generation 
system (BehavePlusPlus?)—another major update possibly done in combination with other fire 
behavior and fire danger systems. We hope that strengths as well as deficiencies of BehavePlus 
will be considered as future systems are developed. In addition to helping users get the most out of 
the BehavePlus system, this report can be a reference for designers of the next generation of fire 
modeling systems.

Information
Information about the BehavePlus fire modeling system, related publications, and training material 
are available at the BehavePlus web site: http://www.FireModels.org. 

Cover Art
“WILDFIRE” © 1992, an original acrylic painting by Monte Dolack. Trumpeter swans take refuge in 
the air as a threatening wildfire rages through the forest habitat. This image is from a 29- by 24-inch 
poster commissioned by the National Wildfire Foundation and used here by permission of the artist. 
All artistic images used in BehavePlus and its associated manuals and training materials are from 
original works by Monte Dolack and appear by permission of the artist.

The use of trade or firm names in this publication is for reader information and does not 
imply endorsement by the U.S. Department of Agriculture of any product or service.
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1 Introduction

The BehavePlus fire modeling system is a computer program that is based on mathemati-
cal models that describe wildland fire and the fire environment. It is a flexible system that 
produces tables, graphs, and simple diagrams. It can be used for any fire management 
application that involves modeling fire behavior and effects, including projecting the 
behavior of an ongoing fire, planning prescribed fire, assessing fuel hazard, and training 
(Andrews 2007). Successful application of the system is dependent upon decisions made 
by the user. Those educated in fire behavior understand the fire modeling foundation 
with the associated assumptions and limitations as well as the influence of various input 
variables on calculated values. An effective fire modeler has a basis of fire and fuel ex-
perience to use in recognizing whether values are reasonable and in making appropriate 
adjustments.

BehavePlus is designed to balance ease of use with options and features that users want 
and need. A user who is satisfied with the “default” selections can quickly run the pro-
gram to get results. If the user has other needs, the program can probably meet them. If 
the user is not satisfied with the form of a table or graph produced directly by Behave-
Plus, results can be exported and reformatted using other software.

BehavePlus offers many features and options to enhance its application. Units and deci-
mal display and the form of the output tables and plots can be changed. The header on 
the worksheet can be expanded to include lines for prescribed fire planning. Wind speed 
can be entered for midflame height or for 20-ft or 10-m height with a wind adjustment 
factor that is either specified or calculated. A user who is aware of the features offered in 
the program can make the most effective use of BehavePlus. A summary list of tips and 
tricks with reference to the relevant section of this paper is provided in Appendix A, and 
Appendices D through H provide reference tables previously available only in the Help 
system: Input Options, Output Variables, Menu Items and Options, Units and Decimals, 
and Appearance Preferences.

This document supplements other published material that describes BehavePlus. The 
User’s Guide (Andrews and others 2008) addresses operation of the program in the form 
of a reference guide. Because additions in Version 5.0 did not change basic operation of 
the program, the Version 4.0 User’s Guide was not updated and remains valid for Version 
5.0. (See the version comparison PDF on the BehavePlus web site.) The Variables paper 
(Andrews 2009), which was updated for Version 5.0, is a reference guide that describes 
the more than 180 input and output variables in BehavePlus. The document is most use-
ful when viewed on a computer, utilizing the numerous links and bookmarks. Both the 
User’s Guide and the Variables paper are bundled with the BehavePlus program as part of 
the Help system.

This publication is not a reference guide like the User’s Guide and Variables paper, which 
are designed to help you find information on a specific topic. Nor is it a step-by-step de-
scription of operation as presented in the lessons (Appendix B) or a manual that teaches 
you how to do fire modeling. This publication’s focus is on program operation, design, 
and features. Even experienced users might not be aware of all of the features described 
in this paper. We explain the program’s design to help the user understand why the pro-
gram behaves the way it does. In some cases, we state that something can be done but 
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do not give you all the details on how to do it because that information is available in the 
 lessons or other BehavePlus guides.

This publication is based in part on material in a series of self-study lessons that were de-
veloped to provide a detailed step-by-step description of various aspects of BehavePlus. 
A list of available and planned lessons at the time of this writing is provided in Appendix 
B. The lessons are organized into units and provide detailed, step-by-step instructions and 
explanation. The Overview Unit describes what BehavePlus is and what it can do. The In-
troduction Unit consists of four lessons that explain basic operation of the program. The 
Operation Unit provides additional lessons on more advanced aspects of operation. The 
Modeling Unit describes the fire modeling capabilities of BehavePlus. This publication 
primarily covers material in the Introduction and Operation Units, with some from the 
Modeling Unit. Again, the focus of this paper is program design, not the fire models.

In addition to BehavePlus lessons, there are formal U.S. interagency training courses that 
include fire modeling concepts (http://training.nwcg.gov): S290–Intermediate Wildland 
Fire Behavior; S390–Introduction to Wildland Fire Behavior Calculations; S490–Advanced 
Fire Behavior Calculations; S495–Geospatial Fire Analysis, Interpretation, and Applica-
tion; and S590–Advanced Fire Behavior Interpretation.

2 Fire Modeling Capabilities
The term model is used in this report for mathematical relationships that describe an as-
pect of wildland fire (Andrews and Queen 2001). Models are generally equations that are 
published in scientific literature. Among the 40 or so mathematical models in BehavePlus 
are flame length, spotting distance, wind adjustment factor, and bark thickness (Table 1). 
BehavePlus (or the old BEHAVE) has sometimes incorrectly been equated with Rother-
mel’s surface fire spread model. While that model (Rothermel 1972) does form the foun-
dation of the SURFACE module in BehavePlus, it is only one of the many fire models 
that comprise the system. Fuel models are not equations but are lists of values needed by 
the surface fire spread model. Therefore, the 53 standard fuel models are considered to be 
one “model.” 

BehavePlus models are grouped into logical groups called modules. Included among 
the nine modules are SURFACE for surface fire behavior, CROWN for crown fire, and 
MORTALITY for tree mortality. Table 2 gives a short description of each module with 
notes on relationships among them. The Module Selection window is shown in Figure 1. 
Indentations indicate where linkages between modules are possible, with output from 
one module used as input to the other. If both modules are selected, the linkage is in ef-
fect. For example, if both SURFACE and SCORCH are selected, they are “linked.” The 
flame length that is calculated in SURFACE is used as input to the scorch height model 
in SCORCH. If SURFACE is not selected, the user must enter a flame length value into 
SCORCH. Using SCORCH without SURFACE can aid understanding of the scorch 
height model. It also allows a person to use observed flame length rather than calculated 
values.

The term system is used for a computer program, nomogram, or some other packaging of 
models, interface, and data into a form that fire managers can use. BehavePlus, FARSITE 
(Finney 1998), FlamMap (Finney 2006), and FSPro (Finney and others, in press) can be 
considered a suite of fire behavior systems. A table showing the relationship among those 
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systems (taken from Andrews 2007) is given in Appendix C. These systems are based 
on many of the same core fire models but are designed for different applications. One of 
the important uses of BehavePlus is for improved model understanding. It is difficult to 
see relationships among variables of interest in the maps produced by spatial systems. 
BehavePlus can be used to exercise the models and systematically examine relation-
ships such as the effect of a choice of a given fuel model or a live fuel moisture value on 
surface fire rate of spread and flame length. While many examples in this paper use the 
SURFACE module, remember that modeling surface fire behavior is just one component 
of the BehavePlus fire modeling system (Table 1).
Table 1—Models that are included in each of the BehavePlus modules with citations (from Andrews 2007).

BehavePlus
module

Model Reference and notes

SURFACE Surface head fire rate of spread, reaction intensity, 
characteristic dead fuel moisture, live fuel moisture of 
extinction, etc . 

(Rothermel 1972)
(Albini 1976a) minor adjustments 

Fireline intensity, flame length (Byram 1959) with adjustments to work 
with Rothermel’s surface fire spread 
model by (Albini 1976b) 

Surface fire flame residence time
(used to calculate fireline intensity) 

(Anderson 1969) 

Direction of maximum spread (Rothermel 1983) using manual 
vectoring 

(Finney 1998; Rothermel 1983) 
calculations based on Rothermel’s 
wind and slope factors 

Fire characteristics chart; relationship among rate of spread, 
heat per unit area, fireline intensity, and flame length 

(Andrews and Rothermel 1982)

Spread in direction from ignition point of a point source fire (Andrews 1986) 

Effective wind speed (Albini 1976b) 

Wind adjustment factor (Albini and Baughman 1979; Baughman 
and Albini 1980; Rothermel 1983) 

Wind speed at 10 m adjusted to 20 ft (Turner and Lawson 1978) 

13 standard fire behavior fuel models (Rothermel 1972) 11 fuel models 
(Albini 1976b) slight revision of 

Rothermel’s 11 plus 2 more fuel 
models 

(Anderson 1982) fuel model selection 
guide 

40 standard fire behavior fuel models (Scott and Burgan 2005) 

Custom fire behavior fuel models (Burgan 1987; Burgan and Rothermel 
1984) 

Dynamic fuel load transfer (Burgan 1979)
(Andrews 1986; Burgan and Rothermel 

1984) as used in BEHAVE
(Scott and Burgan 2005) as used in the 

2005 standard fire behavior fuel 
models 

Two fuel models, weighted rate of spread (Rothermel 1983) 

Two fuel models, harmonic mean (Fujioka 1985) 

Two fuel models, two-dimensional expected spread (Finney 2003) 

Palmetto gallberry special case fuel model (Hough and Albini 1978) 

Western aspen special case fuel model (Brown and Simmerman 1986)
(Brown and Debyle 1987) for mortality 

(continued)
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BehavePlus
module

Model Reference and notes

CROWN Critical surface intensity needed for transition from surface 
to crown fire 

(Van Wagner 1977) 

Transition to crown fire, relationship of surface fire intensity 
and critical surface fire intensity 

(Van Wagner 1989; 1993)
(Finney 1998; Scott and Reinhardt 

2001) 

Crown fire rate of spread, area, and perimeter (Rothermel 1991) 

Critical crown fire rate of spread, needed for an active 
crown fire 

(Van Wagner 1977)

Active crown fire, relationship of crown fire rate of spread 
and critical crown fire rate of spread 

(Van Wagner 1989; 1993)
(Finney 1998; Scott and Reinhardt 

2001) 

Fire type: surface, torching, conditional crown, or crowning (Van Wagner 1993)
(Finney 1998; Scott and Reinhardt 

2001) 

Crown fire flame length (Thomas 1963) 

Crown fire intensity (Rothermel 1991) 

Power of the fire, power of the wind (Byram 1959) 

SAFETY Safety zone size, separation distance, radius (Butler and Cohen 1996; 1998a; 1998b) 

SIZE Elliptical fire size and shape, area, perimeter, length-to-
width ratio 

(Anderson 1983) double ellipse 
(Andrews 1986) simplified to simple 

ellipse 

CONTAIN Fire containment (Albini and others 1978) in the old 
BEHAVE

(Fried and Fried 1996) in BehavePlus 

SPOT Spotting distance from torching trees (Albini and Baughman 1979; Chase 
1981) 

Spotting distance from a burning pile (Albini 1981) 

Spotting distance from a wind-driven surface fire (Albini 1983a; Albini 1983b; Chase 
1984) 

SCORCH Crown scorch height (Van Wagner 1973) 

MORTALITY Tree mortality (Reinhardt and Crookston 2003; Ryan 
and Reinhardt 1988)

(Hood and others 2008) updates for 
version 5 .0 

Bark thickness (Hood and others 2008; Reinhardt 
and Crookston 2003; Ryan and 
Reinhardt 1988) 

IGNITE Probability of ignition from firebrand (Schroeder 1969) 

Probability of ignition from lightning (Latham and Schlieter 1989) 

Fine Dead Fuel
Moisture Tool 

Fine dead fuel moisture tables (Rothermel 1983) 

Table 1 (Continued).
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Table 2—Modules in BehavePlus are groupings of related mathematical fire models.

Module Calculations Linkages 

SURFACE •	 Surface fire rate of spread 
•	 Fireline intensity and flame length
•	 Reaction intensity and heat per unit area
•	 Intermediate values: heat source, heat sink, 

characteristic dead fuel moisture, relative packing 
ratio, etc .

•	 Standard, custom, and special case fuel models
•	 Wind adjustment factor 

CROWN •	 Transition from surface to crown fire
•	 Crown fire rate of spread
•	 Crown fire area and perimeter
•	 Fire type: surface, torching, conditional crown, 

or crowning
•	 Crown fire intensity and flame length
•	 Power of the fire, power of the wind 

•	 Surface fireline intensity or flame 
length can come from SURFACE

•	 Surface fire heat per unit area can come 
from SURFACE 

SAFETY •	 Safety zone size based on flame length
•	 Area, perimeter, and separation distance 

•	 Head fire flame length can come from 
SURFACE 

SIZE •	 Elliptically shaped point source fire
•	 Area, perimeter, and shape 

•	 Head fire rate of spread and effective 
wind speed can come from SURFACE 

CONTAIN •	 Fire containment success for single or multiple 
resources given line construction rate, arrival 
time, resource duration, head or rear attack, and 
direct or parallel attack

•	 Final area and perimeter, fire size at initial attack, 
and fireline constructed 

•	 Head fire rate of spread can come from 
SURFACE

•	 Length-to-width ratio and fire size at 
report can come from SIZE 

SPOT •	 Maximum spotting distance from torching trees, 
burning piles, or wind-driven surface fire 

•	 Head fire flame length can come from 
SURFACE for wind-driven surface fire 

SCORCH •	 Crown scorch height from surface fire flame 
length 

•	 Surface fireline intensity or flame 
length can come from SURFACE 

MORTALITY •	 Probability of mortality from bark thickness and 
crown scorch 

•	 Scorch height can come from 
SCORCH 

IGNITE •	 Probability of ignition by firebrands
•	 Probability of ignition from lightning strikes 
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Figure 1—Fire models are organized according to calculation modules. In this example, SURFACE 
and SCORCH are selected. The indentation of the selected modules, SCORCH under SURFACE, 
indicates that the modules are linked with outputs from SURFACE providing input to SCORCH.

3 Worksheets and Runs
A worksheet is a form that guides user input to BehavePlus. It is built automatically by 
the BehavePlus program based on user selection of modules, input options, and output 
variables so that only the required input values are included on the worksheet. The term 
run is used for a worksheet in which values have been assigned to the required input cat-
egories. Calculate is the menu selection that produces the output pages for a run. 

The worksheet is the foundation of the BehavePlus design. What you see is only part of 
what you get. Worksheet and run files include not only what is visible on your monitor 
but an entire suite of selections. We start with a description of the visible parts of a work-
sheet and related output pages, followed by an explanation of the selections that define all 
aspects of a worksheet. We then discuss using and saving worksheets and runs.

3.1 Worksheet Components and Output Pages
In the following sections, we describe components of the larger BehavePlus window, 
the worksheet, and output pages. Items are numbered in the figures to correlate with the 
descriptions. 
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3.1.1 Window Components
The BehavePlus window header and footer (Figure 2) give information about the pro-
gram, the current run and workspace, and the operation menu and icons. The body of the 
window is the worksheet and results pages, as described in following sections. 

1—Window Label
The window label shows the program name and version number (BehavePlus 5.0.1) and 
the name of the run (not of the worksheet). The name is initially unnamed01.bpr, in-
creasing sequentially with each worksheet that is opened. When a run is saved, the run 
name changes to the file name used when saving. When a run is opened, the name in the 
window header is the file name of that run. More than one worksheet and/or run can be 
open at a time; the header helps you keep track of which file you are viewing. You can 
switch among worksheets or cascade or tile their display using the Windows drop-down 
menu. 

2—Menu Items
The menu items located in the toolbar at the top of the BehavePlus window provide ac-
cess to all of the BehavePlus commands. 

3—Command Icons
Icons are available below the menu items for commonly used commands, especially the 
Module Selection icon and the Calculate icon (circled in green). The arrows let you 
view first, last, next, and previous pages. Hovering the cursor over the icon shows its 
function.

4—Window Footer
The window footer provides the location of the current workspace (Section 9.2). In addi-
tion, the current page number and the total number of pages are given in the footer.

Figure 2—BehavePlus window components, header, and footer. Reference numbers (1-4) refer to 
description in the text.
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3.1.2 Page Layout
A basic design feature of BehavePlus is the page format of 8½- by 11-inch that is suitable 
for printing. The worksheet may carry over from one page to the next. Each output table 
or graph begins at the top of a new page. Wide or long tables may span several pages. A 
run exported to HTML format does not have page breaks, and the exported file can be re-
formatted using a spreadsheet (Section 8.6). The general layout is similar for all Behave-
Plus pages (Figure 3). 

5—Page Header
The header line on each BehavePlus page includes the program name, version number 
(BehavePlus 5.0.1), and page number. When calculations are made, the date and time are 
added. The program version number is useful for future reference. A change log for the 
program is available on the BehavePlus web site that lists bug fixes and also provides 
a summary of updates made with each major version. The date and time in the header 
change each time you Calculate a run, providing a means of matching input and output 
pages if they are separated after being printed. Each worksheet and results page is num-
bered. If portions of BehavePlus input and output pages are included in a report, it is im-
portant to include the page header for complete documentation.

6—Tabs
Tabs can be added to the page layout as an additional means of organization and docu-
mentation using Configure > Appearance preferences > Page Tabs (Appendix H). An 
identical tab is placed on every page of the run. You can create a tab for a related run in 
the next position on the page.

7—Page Border
The page border color and width can be changed using Configure > Appearance pref-
erences > Application (Appendix H). A border width of zero eliminates the border sur-
rounding the page. This setting applies to all worksheets in the current BehavePlus ses-
sion. Any change made using Configure > Appearance preferences > Application is 
preserved between BehavePlus sessions.

Figure 3—BehavePlus page layout showing page header, tabs, and border. Reference 
numbers (5-7) refer to description in the text.
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3.1.3 Worksheet Components 
Items on the worksheet are determined by user selections (Figure 4). The first compo-
nent of the worksheet is the Inputs section. The Acceptable Fire Conditions section is 
included if that option is selected on the Module Selection window. The Run Option 
Notes section includes important reminders of selections that were made to develop the 
current worksheet. The Output Variables section can be included or omitted. The Notes 
section is also optional. 

8—Inputs: Selected Modules
The selected modules are listed at the top of the input section. In this case, both SUR-
FACE and SIZE are selected. The indentation of SIZE under SURFACE in the Module 
Selection window (Figure 1) indicates that the two modules are linked. In this case, the 
head fire surface rate of spread and effective wind speed that are calculated in SURFACE 
are used in SIZE (Table 2). 

9—Description
A description of the run helps you keep track of the purpose of the run, although it is not 
necessary to enter something in this field. The text typed here is used as a header line on 
all output pages and as the default description if you save a worksheet or a run. It is also 
used as the description of a saved custom fuel model or moisture scenario, although you 
can easily change it when you save the file. Other description lines can be added using 
Configure > Appearance preferences > Worksheet. In this example, three additional 
lines were added since the Prescribed fire plan worksheet header was selected.

10—Input Variables by Category
Input variables are organized by category such as Fuel Moisture and Weather rather 
than by module such as SURFACE or SIZE since the same input variable may be used by 
more than one module. The Variables paper (Andrews 2009) includes a table of all input 
variables arranged by category with an indication of the modules in which they are used.

11—Guide Button
The Guide button feature of BehavePlus makes it a much more powerful system. A click 
on the Guide button opens a window with three panes. The left pane is a picture, in-
cluded with permission of the artist to add visual interest to an otherwise grey interface. 
However, if you prefer, the picture can be eliminated on all windows using Configure > 
Appearance preferences > Application, or it can be closed temporarily on the current 
window to enlarge the right-hand Help pane by removing the Picture check mark located 
at the bottom of the window. The center pane provides guidance on entering input values 
(Sections 6.2, 6.3, and 6.4). The right-hand pane is a context-sensitive Help window with 
a description of the variable (Section 15.3). 
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12—Input Values
The worksheet includes lines or input fields for all required input variables. Values must 
be entered for all lines unless they are shaded in blue. Values entered on a blue line are ig-
nored because they are not needed for current calculations. In some cases, an input value 
for one variable (for example, fuel model) determines whether an input is required for 
another (for example, live fuel moisture). In Figure 4, none of the selected fuel models 
contains a live fuel moisture component, and that line is blue. 

13—Acceptable Fire Conditions
This section of the worksheet is added when Table shading for acceptable fire condi-
tions is selected on the Module Selection window (Figure 1; Section 12). 

14—Run Option Notes
Notes are automatically generated for select run options (Appendix D). In this example, 
note that the maximum reliable wind limit IS imposed. A Run Option selection is not 
listed, however, when it is obvious. For example, if fuel moisture is selected to be entered 
by individual size class rather than by dead and live category or by moisture scenario, the 
worksheet requests those values, and an additional note is not needed. 

15—Output Variables
The output variable selections are optionally listed in the Output Variables section and 
can be removed using Configure > Appearance preferences > Worksheet. Although the 
output tables and graphs clearly show the output variables, the list in this section is a use-
ful summary with units and the associated module name. 

16—Notes
The Notes section provides a space for user comments and is helpful in document-
ing a run. This section can be eliminated from the worksheet or the viewing area can 
be changed to as many as 10 lines long using Configure > Appearance preferences > 
Worksheet.
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Figure 4—Example worksheet with input values. Reference numbers (8-16) refer to description in 
the text.
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3.1.4 Output Pages
Once a run has been calculated, results (output) pages will be appended to the worksheet 
(Figure 5). When an input value is changed, results pages are deleted until another Calcu-
late is performed. Saving a run saves the worksheet and the values entered into the vari-
ous fields. To save computer file storage space, output pages are not saved with the run, 
but they can be quickly recreated via the Calculate command. 

17—Table Output
Both table and graph outputs were selected for this example. Each output page begins at 
the top of a new page. In this example, multiple values have been supplied for two input 
variables (fuel model and 1-h fuel moisture), so a table is produced for each of the select-
ed output variables (surface rate of spread, flame length, area, and perimeter). The tabular 
data for surface rate of spread is located on p. 3 of the run. Pages 4 to 6 (not shown) are 
table output for the other three variables. Note that the table header includes the descrip-
tion from the worksheet as well as the name of the output variable. 

18—Graph Output
A graph is also produced for each output variable. This example shows p. 7 of the output 
for surface rate of spread. Pages 8 to 10 (not shown) are graphical output for the other 
three variables. The text entered on the Description line of the worksheet is part of the 
title. Additional lines are added to the heading because the Long version was selected as 
an option for the title using Configure > Appearance preferences > Graph Size.

19—Variable Code Definitions
The last page of the run provides a list of definitions for discrete variable codes. The 
codes listed on this page are only for the values entered on the worksheet. The other 
available option is Show descriptions for all discrete variable codes (Configure > 
 Appearance preferences > Worksheet). In that case, all of the available codes are 
listed on the worksheet under the input line for that variable. It makes sense to show all 
of the codes for some variables such as spotting source location with only four options, 
but it is unreasonable to show all of the codes for the 53 standard fuel models on the 
input worksheet.
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Figure 5—Example output pages. Reference numbers (17-19) refer to description in the 
text.
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3.2 Designing Worksheets
In the previous section, we looked at the visible components of a BehavePlus worksheet. 
In this section, we describe the selections that define a worksheet. All of the selections 
are stored with a saved worksheet or run, not just those that are visible. There is more to 
a worksheet than users might realize. In addition to the selection of modules and output 
variables, the worksheet and run files save your selections for graph size, gridline color, 
curve width, and so on. An overview is provided below, and more detail is given in fol-
lowing sections.

A worksheet is defined by selections, which are applied to the currently open worksheet 
and are saved with the worksheet or run. 
 • Module selection (Configure > Module selection menu item or icon; Figure 1)
 • Input options (Options… button associated with the module; Appendix D) 
 • Output variables (Options… button associated with the module; Appendix E)
 • Units and decimal selections (Configure > Units set selection and Configure > 

Custom units preferences; Appendix G)
 • Appearance of graphs, tables, and worksheets (Configure > Appearance prefer-

ences; Appendix H) 

In addition to selections made for the current worksheet, several selections are preserved 
between sessions, specifically those available on the Configure > Appearance prefer-
ences > Application tab. These selections include whether the Help and Picture panes 
are displayed in the pop-up windows and the worksheet border color and width. A change 
will be applied to all worksheets in the current session and selections are maintained be-
tween sessions.

Selections that are saved with a run are all of those included with the worksheet as well 
as selections that are offered with the Calculate command: display of table and/or graph 
results, selection of the table row variable and of the X-axis variable, and whether the 
 Y-axis limits are specified.

Technically, BehavePlus does not have default selections, which are settings automati-
cally assigned by the program. We have, however, made selections and saved them 
in 0Default.bpw, BasicStart.bpw, and other worksheets available in the Example-
Worksheets folder (Section 3.3.1). All of the available options as well as our selections 
are listed in Appendices D through H. These selections are what we mean when we use 
the word default in this paper. If these settings do not meet your needs, you can save 
your own selections with a worksheet that you can then define as your startup worksheet 
 (Sections 3.3.2 and 3.3.3). BehavePlus defaults are not assigned by the program, but by 
users through selections in the current worksheet.

We discuss below selections that are saved with a worksheet or run, again emphasizing 
that all selections are saved, not just those that appear on the current view.

3.2.1 Module Selection
The Module Selection window is shown in Figure 1. The associated mathematical 
 models for each BehavePlus module are given in Table 1. Indentation indicates that the 
models can be linked, with output from one being used as input to the other. Notes on 
linkages are given in Table 2. 
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3.2.2 Map Distances and Table Shading Options
The Module Selection window includes two additional selections (Figure 1). Checking 
Display output distances in map units adds map distances for distance calculations 
such as spread distance in SURFACE (Section 14.1) that do not need to be explicitly 
 selected as output variables by the user. Checking Table shading for acceptable fire 
conditions adds an additional section to the worksheet (Figure 4). Table shading is 
 described in Section 12.

3.2.3 Input Options
Input options available for each module are accessed via the Options… button associated 
with the module (Figure 1). All of the available input options are given in Appendix D. 
The SURFACE module offers the greatest number of input options, which are separated 
onto several tabs (Figure 6). Navigation arrows at the right (circled in green) allow you to 
see all of the tabs if they do not appear on your screen.

Figure 6—The input options for the SURFACE module are available on the tabs labeled Fuel & 
Moisture, Wind Speed, Directions, and Slope. Other tabs are for output variable selection. If 
you do not see all of the tabs, use the navigation arrows at the right.
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Figure 7—Eight possible output variables are available for the SIZE module. Area and perimeter 
are selected in this example.

3.2.4 Output Variables
Each module has a list of output variables available via the Options… button. Appen-
dix E lists the outputs and default selections associated with each module. The Variables 
 paper (Andrews 2009) includes a table of output variables with units and an indication of 
whether they are available as map distances or as table shading variables. The SURFACE 
module includes the most output variables, separated on several tabs (Figure 6). Figure 7 
shows the output variables available for the SIZE module.

3.2.5 Appearance Preferences
The menu item Configure > Appearance preferences opens a window with several tabs 
that contain options for customization (Figure 8). The Graph Size and Graph Elements 
tabs offer selections that affect graph output (Section 7.3). Page Tabs allows you to add 
tabs to the worksheet as shown in Figure 3. The Tables tab gives you options for table 
format (Section 7.2), including the option of either crossing out values or showing blank 
cells for the table shading option (Section 12). The Worksheet tab lets you modify the 
worksheet (Figure 8). Again, all selections are saved with a worksheet or run.
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Selections on the Application tab (Figure 9) are a special case because they are preserved 
between BehavePlus sessions. We see no reason for you to ever remove the check mark 
from Show help pane. However, if you want to eliminate the pictures from all windows, 
you can remove the check mark by Show picture pane. Alternatively, you can remove 
and restore the picture from the current view using the Picture check box at the bottom 
of each window.

Figure 8—Appearance options are saved with a worksheet or run. This figure shows 
selections on the Worksheet tab. Selections on the Application tab are applied to the 
current session and will remain in effect the next time the program is opened.

Figure 9—Selections made on the Application tab apply to all worksheets and runs in the 
current session and will remain in effect for future sessions.
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3.2.6 Custom Units Preferences and Units Set Selection
Units are assigned to each of the more than 180 variables in BehavePlus for the work-
sheet and run files even though your visible worksheet shows only a few of them. The 
units set also includes the number of decimal places displayed for output variables. A dis-
cussion of units and decimal display options is provided in Section 5.

Configure > Custom units preferences lets you define and save your own set of units 
and decimals. Configure > Units set selection lets you select from our choices for Eng-
lish or metric units as well as your saved custom sets. In addition, you have the option of 
changing units or decimals for the current worksheet without saving a custom set. These 
changes are saved with the worksheet.

3.3 Saving and Using a Worksheet
As noted, the worksheet concept is at the core of the BehavePlus design. The form of the 
worksheet depends on user selections. You can change module selections, output vari-
ables, and input options to adapt a worksheet to your current needs. You can use one of 
the example worksheets that come with the program, or you can use one that you previ-
ously developed and saved. All BehavePlus worksheets have the extension .bpw. More 
than one worksheet can be open at the same time.

3.3.1 Example Worksheets
A few worksheets are packaged with the program in the folder named ExampleWork-
sheets (Figure 10). This folder is write-protected, so you cannot save other worksheets 
there. If you make a change to an example worksheet, you must save it elsewhere. The 
example worksheets were called standard worksheets in earlier versions of BehavePlus. 
But “standard” is a misnomer; they are merely examples that we have developed.

The most important example worksheets are FuelModeling.bpw and FuelModeling-
Metric.bpw because they are set up specifically to handle decimal display for fuel load 
values defined with the Initialize from a Fuel Model option (a change in Version 5.0). 
Explanation is given in Section 5.2. 

Figure 10—Several example worksheets come with the program. The ExampleWorksheets folder 
is write-protected. Worksheets in this folder cannot be changed and new ones cannot be added.
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3.3.2 0Default.bpw and BasicStart.bpw Worksheets
If you open the 0Default.bpw worksheet, it looks blank (Figure 11). But as we have ex-
plained, it includes the full set of selections (Appendices D through H). The only differ-
ence between 0Default.bpw and BasicStart.bpw is the selection of the SURFACE mod-
ule. The 0 in the file name forces it to show up at the top of the list. If you open 0Default.
bpw and select a module, then the default input options, output variables, appearance 
options, and so forth will appear. 

Recall that the defaults are simply our selections. You may want to develop your own set 
of defaults and name it something like 0MyDefault.bpw. For example, you may prefer to 
use more than three colors on the graphs. Rather than making the change every time you 
open a worksheet, you can make the change in your own default worksheet and in other 
saved worksheets.

Figure 11—The 0Default.bpw worksheet appears blank when it is opened, but it includes all 
of the selections for input options, output variables, etc., in the default settings.

3.3.3 Startup Worksheet
The BasicStart.bpw worksheet opens when you first start BehavePlus. You can, how-
ever, change the startup worksheet (File > Set startup worksheet) to another example 
worksheet or to any worksheet that you have saved. If you generally use metric units, this 
saves the steps of starting with BasicStart.bpw and then changing the units set. It is also 
helpful to be able to change your startup worksheet based on your current work effort. 
When working as a Fire Behavior Analyst on a wildfire, you would use a different startup 
worksheet than the one you would use when you are working on prescribed fire planning 
in the office. If you are working on a report, you might have a startup worksheet that pro-
duces graphs in black and white rather than in color.
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3.3.4 Your Worksheets
A folder called MyWorksheets is available for worksheets that you develop and save. 
BehavePlus allows the user to create additional folders to facilitate file organization. For 
example, if you often use metric units, you may decide to open each example worksheet, 
change the units to metric ones, and then save the files. By creating a new folder with a 
meaningful name, such as MetricExampleWorksheets, you can keep the metric work-
sheets in this separate folder to prevent confusion. 

When you save a worksheet, the entry in the Description line of the worksheet is saved 
with the file name. (Note the Description column in Figure 10.) You have the option of 
changing the description at the time you save the worksheet. To create a new folder for 
worksheets, simply enter a new folder name in the Worksheet Folder field. 

You can give a folder of worksheets to someone else who can use his or her computer’s 
file management program (such as Windows® Explorer) to put it in their Worksheet-
Folder (Section 9.1). In Figure 12, example worksheets were saved in a folder named 
BugTest and were given to the programmer.

Figure 12—A folder of worksheets can be given to someone else to put in their WorksheetFolder. 
The folder includes the .bpw worksheet files and a small file with the description of the folder.

3.4 Saving and Using a Run
Recall that the difference between a worksheet and a run is that a run has values entered 
on the worksheet. All worksheet selections are saved with a run. In addition, a saved run 
includes selections made on table and graph outputs following a Calculate command. 
When a run is saved, the results are not saved. Results can be recreated by simply open-
ing the run and recalculating the results. All BehavePlus runs have the extension .bpr.
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3.4.1 Calculate Options
When you calculate a run, you specify whether you want table and/or graph output and 
make selections on the table row variable and the X-axis variable. You can either let the 
program scale the graph to the maximum calculated value or you can specify other Y-axis 
limits (Section 7.3.3). Selections in the Calculate Results window are saved with a run, 
but not with a worksheet (Figure 13). 

Figure 13—Selections in the Calculate Results window are saved with a run.

3.4.2 Example Runs
Similar to ExampleWorksheets, the write-protected folder named ExampleRuns pro-
vides several sample runs with the BehavePlus program. For example, the FuelHerb-
Mois.bpr run produces plots of surface rate of spread and flame length for several fuel 
models for a range of live herbaceous fuel moisture values (Figure 14). You can quickly 
open this run and change the fuel models to produce another comparison plot. 
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Figure 14—The example run FuelHerbMois.bpr reveals the impact of fuel model selection on 
surface rate of spread for a range of herbaceous fuel moisture.
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3.4.3 Your Runs
A folder called MyRuns is available for runs that you develop and save, but you can cre-
ate additional folders and give them meaningful names. You can give a folder of runs to 
someone else, as described for worksheets (Section 3.3.4).

BehavePlus runs prepared for a project such as prescribed fire planning or wildfire pre-
diction should be saved in a separate documentation file for future reference. The work-
space feature of BehavePlus is useful for this purpose (Section 9.2). 

4 Display and View Features

In this section, we group a discussion of several topics related to display: 
 • changing the size of the displayed BehavePlus page (Section 4.1), 
 • viewing multiple runs simultaneously (Section 4.2),
 • moving quickly between BehavePlus pages (Section 4.3), 
 • changing graph size (Section 4.4), 
 • expanding the Help window for better viewing (Section 4.5), and 
 • exploring Help system PDF documents using bookmarks and links (Section 4.6).

4.1 Window and Page Size
When BehavePlus opens, the window is sized to fit the worksheet. The window size 
can be changed by dragging the sides, but the BehavePlus page size doesn’t change. To 
change the worksheet display size, use View, located on the toolbar (Figure 15). A check 
mark highlights the current display size. Reducing the view percentage is useful for dis-
playing an entire page on a small monitor or for screen captures. Increasing the percent-
age will make the text easier to see in presentations.

Figure 15—The View item in the toolbar allows you to 
change the size of the display on your monitor.
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Figure 16—The Windows drop-down menu allows a switch between runs or simultaneous display 
of multiple runs.

4.2 Multiple Windows
The Windows menu option allows a switch from one worksheet/run to another or for 
simultaneous display of multiple runs (Figure 16). The active run is marked with a check 
mark. This option is useful when doing comparison runs. 

4.3 Page View 
As previously noted, BehavePlus is designed around producing pages suitable for print-
ing. To view the next or previous page or to go to the first or last page, use the vertical 
blue arrows located on the toolbar. To jump directly to the page you want to see, use 
Pages on the toolbar (Figure 17). In this example, there are 11 pages: 2 input pages, 4 
pages of tables, 4 pages of graphs, and 1 page for discrete variable codes. In addition to 
a specific description of the page, the icons in the list help you quickly jump to the first 
graph, for example.
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Figure 17—The Pages command on the toolbar lets you jump to the page you wish to view. 
In this example, there are two input pages, four table pages, four graph pages, and one codes 
page.

4.4 Graph Size
The size of the graphs with respect to an output page can be changed from the default of 
50% using Configure > Appearance preferences > Graph Size (Figure 18). A change 
to 100% fills the page. A change to 75% is shown in Figure 18. When you change any 
Appearance preferences, run outputs disappear; click Calculate to recreate the run us-
ing the new preferences.
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Figure 18—The graph in Figure 14 was changed from 50% to 75% using Configure > Appear-
ance preferences > Graph Size.
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4.5 Help Window
The Help window is a major feature of BehavePlus. Context-sensitive Help information 
is provided in the right-hand pane of every pop-up window (Figure 19). The Index button 
in the pop-up window provides access to other help topics. The Help system is discussed 
in more detail in Section 15. 

It can be useful to maximize an Input Guide window to see tables and graphs included 
in the Help window. You can also show more of the Help window by temporarily turning 
off the Picture using the check box at the bottom of each Help window. You can turn off 
all pictures using Configure > Appearance preferences > Application (Section 3.2.5). 

Figure 19—Context-sensitive Help information is provided in the right-hand pane of every window. 
Uncheck Picture to remove the picture on the current window to give more room to the Help pane. 
Guidance is given on canopy bulk density for Douglas-fir/Lodgepole pine in this Help window.

4.6 PDF Documents
The User’s Guide and Variables papers are included as PDF documents available from 
Help on the main menu (Figure 20; Sections 15.1 and 15.2). 
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Figure 20—The User’s Guide and Variables paper (“Vari-
able Help”) PDF documents can be opened through Help 
on the toolbar.

Bookmarks and links in the documents help you find what you need (Figure 21). You 
may need to change settings in Adobe® Acrobat or Reader to take full advantage of the 
documents. If the bookmarks in the left-hand column do not appear in Adobe® Acrobat, 
place a check mark next to View > Navigation Panels > Bookmarks. The bookmark 
icon should then appear on the left side of the window. You can expand the bookmarks by 
clicking on the + sign. In addition, a Page Navigation Toolbar allows you to move easily 
from link to link through the paper. If the right- and left-hand arrows do not appear, click 
on View > Toolbars > More Tools… and scroll down to the options for Page Navigation 
Toolbar. Select First Page, Previous Page, Next Page, Last Page, Previous View, and 
Next View. 
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Figure 21—If a PDF document has bookmarks, they can be accessed via the Bookmarks toolbar. 
There is also a Page Navigation Toolbar to aid in moving quickly through a document.

5 Units and Decimals
One of the design objectives of BehavePlus was to give the user control over units and 
decimal display. As with many options, this flexibility comes with a responsibility to 
understand how the program works. Of course, as with other options in BehavePlus, you 
can avoid the issue by accepting the default settings.

BehavePlus offers a simple switch between English and metric units (Configure > Units 
set selection). Alternatively, units can be changed for individual input and output vari-
ables, and the number of decimal places displayed can be changed for output variables. 
The number of decimal places for input variables is determined by the values entered on 
the worksheet. Custom units sets, which include decimal display for output variables, 
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can be saved for later use. It is also possible to change units and decimals on a worksheet 
without saving a custom units set; changes to units and decimals are always included in 
saved worksheets and runs. In addition, BehavePlus includes a helpful Units converter 
tool (Section 5.5). Specifics of units and decimal features are described in the following 
sections.

Because of issues that can arise due to round off and unit conversions, some basic chang-
es have been made to decimal handling in Version 5.0. We recognize that there is some 
awkward behavior in decimal display resulting from program design decisions that were 
made years ago, but this cannot be changed without a major redesign.

BehavePlus calculations are performed in what we call native units, the units of the pub-
lication that describes the mathematical model. This explains some of the behavior that 
might seem odd. For example, Rothermel’s model uses fuel load in lb/ft2 and fuel model 
parameters are stored in those units. The default display units are tons/ac. The 1-h fuel 
load for fuel model 5 is stored internally as 0.046 lb/ft2, which is equivalent to 1.00188 
ton/ac.

Most users will use the same units set (our English or metric or their custom set) for all 
of their runs and will not switch back and forth between units sets. We have attempted to 
make the units and decimal handling easiest for the largest user group.

5.1 Input Variable Decimals
Prior to Version 5.0, decimal display of input variables was determined by the setting in 
the English, metric, or custom units set. Because the program uses values that are visible 
on the worksheet to make the calculations, there were occasional problems with round off 
and misinterpretation. Decimal display of input variables is now determined by the values 
entered by the user. The greatest number of decimal places (precision) entered for a vari-
able determines the decimal display on output tables. In the example in Figure 22, one 
of the values entered for dead fuel moisture was 9.25% (two decimal places) so all of the 
dead fuel moisture values on the output table are shown with two decimal places. (This 
example simply demonstrates the way that the program handles decimal display; a mois-
ture value to that precision is not meaningful.) Similarly, a value of 6.5 mi/h was entered 
for midflame wind speed, so all of the wind values are shown on the table to one decimal 
place.
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5.2 Fuel Model Parameter Decimals
Assigning values for fuel parameters is a special case because of the way that input val-
ues are assigned using the worksheet option to Initialize from a Fuel Model. If you are 
developing custom fuel models, it is best to use the FuelModeling.bpw or FuelMod-
elingMetric.bpw worksheets from the ExampleWorksheets folder. These worksheets 
have been designed to display six decimal places for fuel load values to avoid round off 
problems (Figure 23). 

Figure 22—The number of decimal places for input variables that are displayed as rows or col-
umns on table output is determined by the greatest number of decimal places entered as input for 
that variable.
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If you prefer to use fewer decimal places, you can develop a similar custom fuel model 
worksheet by starting with the BasicStart.bpw worksheet and changing the input option 
to Fuel is entered as Fuel parameters. In this case, the initialized fuel load values will 
show two decimal places (Figure 24). In both examples (Figures 23 and 24), the values 
are obtained using Initialize from a Fuel Model and fuel model 2.

Figure 23—FuelModeling.bpw and FuelModelingMetric.bpw worksheets are special case work-
sheets developed to avoid round off problems when creating custom fuel models. Six decimals are 
shown for fuel load values when Initialize from a Fuel Model is used in these two worksheets.
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Figure 24—When a worksheet is set up by starting with the BasicStart.bpw worksheet and the in-
put option is changed to Fuel is entered as Fuel parameters, only two decimal places are shown 
when Initialize from a Fuel Model is used.

5.3 Units Set Selection
You can quickly use Configure > Units set selection to change among the default 
 English, metric, or custom units sets that you have previously developed and saved 
 (Figure 25). Decimal display for output variables is part of the units set.

Figure 25—You can change the units set (which 
includes output decimal display) to English, metric, or a 
custom set using Configure > Units set selection.

If you enter values on the worksheet and then change the units set, six decimal places 
are displayed for the converted values, although trailing zeros are suppressed. This is a 
change in Version 5.0. It resolves a problem with round off that sometimes occurred in 
previous versions. This solution is awkward in some cases, but won’t affect most users 
who generally do not switch back and forth between units sets. 
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5.4 Custom Units Preferences
A custom units set defines units for all variables in BehavePlus and the decimal display 
for output variables. Changes may be made using Configure > Custom units preferenc-
es (Figure 26), which are then applied to the current worksheet. Changes can be saved for 
future use, if desired. You may want to create a custom units set if, for example, you pre-
fer to use ft/min for rate of spread rather than ch/h. Or you might create a units set with 
English units for everything except canopy bulk density, which is commonly expressed in 
kg/m3. 

There are over 180 variables in BehavePlus, which are divided into groups for purposes 
of assigning units and decimal display (Appendix G). The units are assigned by category. 
Units for all variables in that group will be changed. The Help window lists the variables 
assigned to each group (Figure 26).

You do not have to save a custom units set to apply changes to the current worksheet. 
You have the option of saving changes in a custom units set or only applying changes to 
the current worksheet (Figure 27). In either case, the changes will be saved with the cur-
rent worksheet or run. Figure 28 shows the output table from Figure 22 after reducing the 
number of decimals for Surface ROS from 1 to 0. If you are going to use different units 
and decimals often, you will want to save them as a custom units set, which can be ac-
cessed by clicking on Configure > Units set selection > Custom. 

Figure 26—The decimal display for output variables is changed by Configure > Custom units 
preferences. Variable grouping is given in the Help window and is in Appendix G. Variables that 
only serve as input do not have the option to change decimals.
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5.5 Units Converter Tool
The units conversion tool (Tools > Units converter) is a flexible tool for converting a 
quantity between any two related but arbitrary units of measure (Figure 29). The quantity 
to be converted can be an integer or a real value in either decimal or scientific notation 
(for example, 0.0005 or 5e-4). Units can be entered as common abbreviations (for ex-
ample, pounds per foot2, lb/ft2, lb ft-2, or lb per ft2). An error message will describe a 
problem with an entry such as an attempt to convert from feet to kilograms. A long list of 
units of measure can be found in the Help window.

Figure 27—Changes to units and decimals are always applied to the current worksheet. A custom 
units set file can be saved for future use or used only in the current worksheet/run.

Figure 28—The results from the run in Figure 22 after a change in the number of decimal places 
from 1 to 0 for Surface ROS (Figure 26).
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6 Methods of Input
There are various ways to specify input values to BehavePlus. A particular strength of 
BehavePlus is the ability to display the influence of inputs on calculated fire behavior 
(such as the effect of increasing wind speed on rate of spread). Ranges of values are en-
tered to produce tables and graphs. Rarely should a user only enter a single value for each 
input variable and accept the results. You will most often enter multiple values for input 
variables before settling on selections.

There are no traditional data files for BehavePlus. Data are entered into a worksheet inter-
actively by the user. Once data have been entered in BehavePlus, however, the worksheet 
can be saved as a run. Fuel parameter values can be saved as a custom fuel model (Sec-
tion 10.1), and surface fuel moisture values can be saved as a custom moisture scenario 
(Section 11.1). 

Input variables are categorized as either continuous or discrete. Continuous variables are 
assigned numerical values. Any value in the valid range can be entered. For example, 
dead fuel moisture percentage can have a value of 4, 4.5, or 5. Discrete variables, on the 
other hand, can have only specific values or codes. For example, a fuel model can be en-
tered as 4, 5, or GR2, but 4.5 is not a valid fuel model code. A table in the Variables paper 
(Andrews 2009) describes which variables are discrete and which are continuous, but Be-
havePlus handles the input options for each variable type appropriately and will provide a 
warning if inputs are entered incorrectly.

In all cases, values can be directly typed into the worksheet. Alternatively, a click on the 
Guide button associated with each input variable offers a list of valid values for discrete 
variables. The Guide button gives a means of entering one, two, or a range of values for 
continuous variables. For some continuous variables, there is also a Choices button that 

Figure 29—The Units Converter tool quickly converts a value from one unit of measure to 
 another.
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displays some common values. Additional guidance on input values is available for some 
variables in the associated Help window. Following is a description of the various meth-
ods of input.

6.1 Direct Input
A common method of inputting data is to type them into the input field on the worksheet. 
Values can be separated by commas, spaces, or any combination of the two (Figure 30). 
Values can be typed in any order in the box; however, the order of entry determines the 
order of values on output tables and the order that labels are put on graphs. 

Figure 30—Data can be input directly and separated by commas, spaces, or a combination of the 
two.

6.2 Discrete Variable Selection
Discrete variables are those for which only specific values are meaningful. As an alterna-
tive to typing a value, a click on the Guide button gives you a list of all possible values 
(Figure 31). Items in the Value column are those entered in the input box. The Descrip-
tion column provides information about the item. If you click on a line, it will turn blue, 
indicating selection. You can select multiple values by clicking on several lines; you do 
not need to hold down the control (Ctrl) key. Clicking on a selection again will remove 
the blue indicator, and the value is no longer selected.

As an example, if you click on the fuel model Guide button, the 53 available standard 
fuel models are shown. Custom fuel models are added to the list when they are first de-
veloped and, in future sessions, when their folder is attached (Section 10.2). The list can 
be sorted by a click on the column headers, if desired. 
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6.3 Ranges for Continuous Variables
Any value within a range of valid values can be entered for a continuous variable. A table 
in the Variables paper (Andrews 2009) provides valid ranges and default English and 
metric units for each input variable. 

If you click on the Guide button beside a continuous variable, an Input Guide window 
will appear (Figure 32). The valid range and units of the variable are shown above the 
input boxes. You might use the Guide button to enter a single value when you want to 
check the valid range. You might enter only starting and ending values when you are pro-
ducing a plot. Typically, a range of values is entered: the start value (From), the ending 
value (Thru), and the Step. 

You can enter values in reverse order by putting the highest value in From, the lowest 
value in Thru, and entering a negative Step size. This has no effect on graphs but can be 
useful in formatting tables. For example, a table of dead fuel moisture versus wind speed 
can be organized as increasing wind and decreasing moisture, showing changes in the di-
rection of higher flame length values.

Figure 31—The Guide button provides access to a list of available selections for discrete variables 
such as fuel model. Select and deselect values by clicking on them.
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Figure 32—Continuous data can be input as a range of values. The valid range and units are 
shown above the input boxes. Use a negative step size to organize a table from larger to smaller 
values (for example, fuel moisture).

6.4 Choices for Continuous Variables
There is a Choices button at the bottom of the Input Guide window for some continu-
ous variables. A list of selected input values is given. This is different from the list for all 
possible discrete variables. It is meant to provide some help and guidance. For example, 
choices for 1-h fuel load gives values for the 13 fuel models. Map scale gives values in 
several forms (such as 1:x, in/mi, cm/km, and km/cm) for commonly used map scales. 
Crown bulk density values are listed in units of both lb/ft3 and kg/m3. Slope steepness 
choices are provided in both percent and degrees, giving a quick reminder that a slope of 
550% is equivalent to a slope of 80° (Figure 33). 
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Figure 33—For some continuous variables, the Choices button gives a list of selected (not all) 
values for guidance (a). For example, slope steepness values are given in both percent and 
degrees (b).

(a)

(b)
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6.5 Additional Guidance
In addition to the values that might be in a Choices list, there is additional guidance for 
some input values in the Help window. For example, canopy bulk density photos and 
data are given for several forest types (Figure 19). Line construction rate tables from the 
Fireline Handbook (National Wildfire Coordinating Group 2004) are included. Wind ad-
justment factor diagrams and tables are provided (Figure 34).

Figure 34—The Help window includes guidance for selecting values from some input variables, 
such as wind adjustment factor.
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7 Form of the Output
BehavePlus can produce calculated values in the form of simple lists, tables, graphs, and 
simple diagrams. Default selections can be accepted, and a user need not be concerned 
about making choices because the program will generate standard outputs. There are, 
however, many options that can be used to produce output in a form desired for a given 
application.

The form of tables and graphs depends on the variable type (continuous or discrete) and 
number (zero, one, or two) of input variables that are assigned ranges. If input variables 
are each assigned a single value, an output page will be produced as a simple list of re-
sults. If one or two variables are assigned multiple values, tables and graphs can be creat-
ed. Simple diagrams are produced by selecting a diagram variable from the list of output 
variables. Various aspects of tables, graphs, and diagrams are described below to help you 
make best use of BehavePlus. 

An important consideration in all cases is that the input worksheet, including the program 
version number and assigned values, should always accompany the results. Model output 
is meaningless unless all of the information used to produce it is clearly documented.

7.1 List
If a single value is entered for each input variable, a simple list of output is produced 
(Figure 35). We encourage you to look at tables and graphs with ranges of values before 
you settle on the single values. 
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Figure 35—If a single value is entered for each input variable, a simple list of output values is 
produced. However, we strongly suggest looking at ranges of input values before deciding upon the 
best values to use.

7.2 Tables
The form of the table depends on whether multiple values are entered for one or two vari-
ables, selections on row and column variables, and appearance preferences. If multiple 
values are entered for more than two variables, an error statement is produced. 
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If multiple values are entered for one input variable, that variable defines the table rows 
and each selected output variable is given as a table column (Figure 36). If the number of 
output variables requires that the table continue onto another page, the input column and 
values are repeated on each page.

Figure 36—When one variable has a range of values (for example, midflame wind speed), a table 
is produced, with that variable defining the rows of the table and the outputs in the columns.

If multiple values are entered for two input variables, a separate table is produced for 
each of the selected output variables. Consider a table of calculated surface rate of spread 
for two fuel models and several midflame wind speed values. In this case, 2 rows and 10 
columns carry over to a second page (Figure 37). The diagram in the upper left-hand cor-
ner and arrows on table column heading illustrate this fact. 
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Figure 37—When multiple values are entered for two input variables, a table is produced for each 
output variable. If a table extends beyond a page, it is indicated by the diagram in the upper left 
corner and by the arrows on either side of the table.
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By default, the first input variable on the worksheet with multiple values is selected as the 
row variable and the second as the column. A switch in the Calculate Results box to us-
ing midflame wind speed as the Table Row Variable (Figure 38) produces a more 
appropriately formatted one-page table (Figure 39). 

Note that the entry in the worksheet’s Description line is repeated at the top of each 
table. In this simple example, it was possible to include all of the relevant input values in 
the heading.

The look of the table can be changed via Configure > Appearance preferences > 
 Tables. The color used to shade alternate lines for readability can be changed (as in 
Figure 39), or the shading can be removed (Figure 40).

Figure 38—The table format can be changed after the Calculate command by selecting the table 
row variable.
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Figure 39—This is the table in Figure 37 with switched row and column variables. The color of the 
line shading was changed using Configure > Appearance preferences > Tables.
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7.3 Graphs
It is sometimes easier to see relationships in graphs than in tables. Graphs are especially 
useful in examining model sensitivity and making comparisons. BehavePlus produces 
line graphs and bar graphs. The type of variable (continuous or discrete) determines the 
form of the graph (line or bar); it is not a user selection. The user has control of many 
aspects of graph appearance, including selection of the X-axis variable, line colors, graph 
size, and grid. All of the graph options and default selections are given in Appendix H. 
Examples of graphs of one or two continuous or discrete variables, some appearance op-
tions, and axis and scale change options are given below.

Figure 41 shows a bar chart of flame length for multiple values entered for the discrete 
variable, fuel model. We compare the 12 litter fuel models for constant moisture, wind, 
and slope conditions. 

Figure 40—Alternate line shading in Figures 37 and 39 can be eliminated using Configure > 
 Appearance preferences > Tables.
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Figure 41—A bar graph (middle) is produced for multiple values of a single discrete 
variable. In the graph, flame length is compared for litter fuel models for constant 
conditions. The last page of output (bottom) is a list of code definitions for the fuel 
models used in the run.
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When we change the run shown in Figure 41 by assigning a range of values to the contin-
uous variable midflame wind speed, a curve is produced for each fuel model (Figure 42). 
Multiple points are calculated for each curve using the maximum and minimum values 
that you entered, not the intermediate values that are used to produce a table. The number 
of points calculated to produce each line on the graph is determined by the Curve points 
setting under Configure > Appearance preferences > Graph Elements. There is little 
reason to change from the default of 100. Values between curve points are connected by 
straight lines. 

Figure 42—The wind speed of 5 mi/h used for Figure 41 was changed to 0 and 8 mi/h. A 
range of midflame wind speed values produces a curve for each fuel model.
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7.3.1 Appearance Change
Figure 43 uses the same input values as Figure 42, but changes were made to make the 
graph easier to read. We moved fuel models 8, 9, and 10 on the worksheet to fit better 
with the fuel models TL1 through TL9 to improve curve labeling. The fuel model order 
was revised to become “tl1, tl2, tl3, 8, tl4, tl5, tl6, tl7, 9, tl8, tl9, 10.” We also changed the 
number of colors from 3 to 12 and the gridline color from yellow to grey (both in Config-
ure > Appearance preferences > Graph elements), and we changed the graph size from 
50% to 70% (Configure > Appearance preferences > Graph Size). 

Figure 43—Changes were made to the graph in Figure 42. The number of colors 
was changed from 3 to 12. Grid color was changed from yellow to grey. Graph 
size was changed from 50% to 70%. The order of the fuel models on the work-
sheet was changed to improve curve labeling.
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Figure 44 is another example of changing graph appearance. Curves for four of the fuel 
models from Figure 42 are plotted. The curve color was changed to black.

Figure 44—Four fuel models from Figure 43 were plotted with line color changed to black.

7.3.2 Axis Change
If multiple values are entered for two continuous variables, the X-axis variable can be 
defined as either one of them, and the selection can produce quite different results. The 
calculations are the same, but the form of the graph can convey different information. 
The X-axis variable is initially selected as the first one on the worksheet. Figure 45 
shows graphs first with dead fuel moisture as the X-axis variable with a curve for several 
midflame wind speed values and then with midflame wind speed selected as the X-axis 
variable.
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Figure 45—When a graph is produced for ranges of two continuous vari-
ables (a), either one can be designated as the X-axis variable. Both graphs 
(b) and (c) are from the same input values. The only difference is in the 
selection of the X-axis variable.

(a)

(b)

(c)
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7.3.3 Scale Change
In the default settings, the minimum value for both axes is zero, the maximum for the X-
axis is based on the maximum value that was entered, and the maximum for the Y-axis is 
based on the maximum calculated value.

While it is generally best to keep the graph origin as (0, 0) to avoid misinterpretation, it 
can be changed to the minimum entered value for the X-axis and the minimum calculated 
value for the Y-axis (Configure > Appearance preferences > Graph size). In Figure 46, 
the X-axis origin is changed from zero to the minimum value to better examine live fuel 
moisture from 75% to 125%.

(a)

(b)

Figure 46—Using the inputs in (a), the graph with the origin at (0,0) in (b) was changed 
to the minimum X-axis value in (c) using Configure > Appearance preferences > 
Graph Size.

(continued)
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Comparing two graphs is easiest when they have the same scale for the Y-axis. A change 
from fuel model GR2 in Figure 46 to GR1 produces the graph in Figure 47. In order to 
better compare surface rate of spread for the two fuel models, the maximum value for the 
surface rate of spread axis was changed from 10 to 50 ch/h to produce the graph in Fig-
ure 48. This was accomplished by checking Specify graph Y axis limits in the window 
that appears after performing the Calculate command. The maximum calculated value is 
shown for reference in the following window where it can be changed (Figure 49).

(c)

Figure 46—Continued from previous page.

Figure 47—Fuel model GR2 in Figure 46 was changed to GR1. The Y-axis (sur-
face rate of spread) is automatically scaled to the maximum calculated value for 
GR1.
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Figure 48—The scale for surface rate of spread in Figure 47 was changed from a 
maximum of 10 ch/h to 50 ch/h to better compare outputs from fuel model GR1 to 
the similar plot for fuel model GR2 (Figure 46). The method for changing the Y-axis 
scale is shown in Figure 49.

Figure 49—Selecting the Specify graph Y axis limits in the Calculate Results 
window (a) will bring up a Graph Limits Dialog window (b), allowing a change to Y-axis 
minimum and/or maximum values.

(a)

(b)
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7.4 Diagrams
In addition to tables and graphs, BehavePlus will create diagrams for four variables: fire 
characteristics chart in SURFACE, wind/slope/fire spread directions in SURFACE, point 
source fire shape in SIZE, and the shape of a fire after suppression action (successful or 
not) in CONTAIN. Diagrams are generated by selecting them from the list of output vari-
ables for the module. Diagrams can aid model understanding and interpretation. 

Diagrams are produced for values in the output tables. Therefore, if only graph output is 
selected, diagrams will not be produced. All of the diagrams for a single run use the same 
scale. It is generally not good practice to request too many diagrams in a single run. Fig-
ure 50 shows table output and four associated diagrams. In this case, fire shape diagram 
was chosen as an output from the SIZE module.

Figure 50—Fire shape diagram was selected as an output variable for the SIZE module. A diagram 
is produced for each value in the table output.

(continued)
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Figure 50—Continued from previous page.

(continued)
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Figure 50—Continued from previous page.
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8 Using Outputs Elsewhere
Fire modeling results from BehavePlus are often included in documents. This can be ac-
complished in various ways, most simply by attaching BehavePlus printed pages to a re-
port. Portions of BehavePlus pages might be captured and inserted into a document (such 
as this one). Table results can be exported as an HTML file, which does not have the Be-
havePlus page layout. Spreadsheet or other software can then be used to produce graphs 
in ways that are not possible within the BehavePlus program. 

It is worth repeating that complete information (program version number, input values, 
selected options, etc.)—in other words, enough information to re-create the run—must 
always be included with results. Tables of flame length or plots of spotting distance are 
useless if the information used to obtain those values is not provided.

8.1 Print Output
File > Print allows you to print all BehavePlus pages or a range of pages. There is no op-
tion for two-sided printing.

Figure 51—File > Print gives the option of printing se-
lected pages. The Adobe PDF option, however, creates 
one page at a time, allowing you to change the name of 
the file as each page is saved.

8.2 Save as PDF
If you have the ability to create PDF documents on your computer using Adobe® Acrobat, 
the BehavePlus command File > Print will give Adobe PDF as an option (Figure 51). 
Although it does not behave as you might hope, it does give you the option of converting 
pages to PDF. Rather than saving all pages in the listed page range, it converts one page 
at a time, triggering a pop-up window that allows you to change the file name for each 
page. You can name each page and later combine them into a single document. Although 
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the BehavePlus window view does not change from page to page, repeated saves of the 
PDF file move from page to page, starting with the first. Following are the steps to save 
all pages in a PDF document in Adobe® Acrobat:
 • File > Print > Adobe PDF > Print
 • Save in: (create a folder for the document)
 • File name: (change the default BehavePlus5.pdf to p1) > Save
 • File name: (change the default BehavePlus5.pdf to p2) > Save
 • (Repeat for all pages)
 • When all pages are saved, the Print window closes. If you wish to save fewer pages, 

click Cancel multiple times to close the print window.
 • Open p1.pdf
 • Document > Insert Pages > From File
 • Highlight p2.pdf through the last page > Select
 • Location: > After > Last > OK
 • File > Save as > (name your document)
 • Delete intermediate files and folder.

8.3 Save as Image
BehavePlus includes the option of saving each page as an image with File > Save as an 
image. A file is created for the currently viewed page in BMP, JPG, or PNG format (BMP 
files may be very large). Each page has to be captured separately. The saved file can then 
be inserted into a document and cropped as in the method described below. 

8.4 Capture, Insert, and Crop 
The BehavePlus Save as an image option is awkward and limited. We therefore recom-
mend alternate methods. Commercial software can easily be used to capture portions of 
input and output for reports and publications. (We used FullShot® for the figures in this 
paper, although there are a number of commercial and freeware products available.) 

Following is a capture method that is commonly available on Windows®-based computers. 
 • Open a Microsoft® Word document. 
 • Click on the BehavePlus screen to make it the active screen.
 • Simultaneously press the two keys Alt and PrintScrn to capture only the Behave-

Plus window. (PrintScrn alone captures the entire computer screen.)
 • Click on the Word document where you want the image.
 • Simultaneously press Ctrl and the letter v (Ctrl-v), use File > Paste (Word 2000 or 

2003), or use Paste on the Home > Clipboard Task Pane (Word 2007) to insert the 
window into the open Word document.

 • Click on the inserted BehavePlus image in the Word document.
 • To use the crop feature in Word 2000 or 2003, make sure the Picture Toolbar is 

available. If it is not, click on View > Toolbars > Picture. In Word 2007, the crop 
tool is found under the Picture Tools > Format tab. 

 • Crop the image to the desired portion by clicking on the image, using the Word crop 
feature, and dragging the cursor to the appropriate location.
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8.5 Export as HTML
BehavePlus offers the option using File > Export results to export input and table output 
(not graphs or diagrams) as an HTML file, which can be viewed with an Internet browser 
(Figure 52). You can choose to save the file in the BehavePlus folder MyExports, or you 
can navigate to another location on your computer. BehavePlus page formatting is not 
carried over to the HTML file. For example, long and wide tables are not split onto mul-
tiple pages.

In some cases, the report may look nice in the browser but may not print correctly. To 
change the settings in Internet Explorer (Version 8.0): 
 • Select Tools > Internet Options. 
 • Select the Advanced tab. 
 • Scroll down to the Printing header. 
 • Enable the check box titled Print background colors and images. 

To change the settings in Mozilla Firefox (Version 3.5): 
 • Select File > Page Setup. 
 • Select the Format & Options tab. 
 • Enable the check box titled Print Background (colors and images).
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Figure 52—File > Export results saves BehavePlus input and table output (not graphs or dia-
grams) in HTML format, which can be viewed with a web browser. BehavePlus page formatting 
that splits long and wide tables is not exported.
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8.6 Export to Spreadsheet
You may want to perform additional analysis of results from BehavePlus, such as making 
comparisons to a new fire model under development. Or you might wish to plot results in 
a way not offered by BehavePlus, such as plotting two variables on the same graph. The 
HTML file can be opened with spreadsheet software where additional calculations and 
formatting can be done. In this description, we use Microsoft® Excel 2007 as the example 
spreadsheet program. When you save a file using File > Export results, you will get a 
reminder message that you can open the HTML file with Excel.

To graph results, BehavePlus calculates multiple points for each graph using the maxi-
mum and minimum values that you entered but not the intermediate values. The num-
ber of calculations for each curve is determined by the appearance option (likely 100 
points). However, the export function only applies to the values in the tables produced 
by BehavePlus, so there must be enough data in the table to create an accurate graph in a 
spreadsheet. You might not need 100 values. For example, if you are interested in flame 
length values associated with wind speeds from 0 mi/h to 20 mi/h, BehavePlus will create 
a plot based on those two values. For export, you must input intermediate values between 
0 and 20 mi/h (for example, from 0 to 20 in steps of 1) to produce a table suitable for 
graphing in a different program. 

To open the HTML file as a spreadsheet, locate the file on your computer, right-click on 
the file name, and select Open With > Choose Program…. Select Microsoft® Excel (or 
any desired program that that can interpret HTML files). Once the values are loaded into 
a spreadsheet, you can work with them as you see fit. It is essential that you save the doc-
ument in spreadsheet format (File > Save As…) and change the file extension from .html 
to the appropriate extension (.xlsx in our example), so that any changes will be properly 
saved. It is best to save the file as a spreadsheet as soon as the file is opened and before 
any additional work is done. 

Once the file has been saved as a spreadsheet, a good approach is to leave the imported 
page as it is and copy the relevant output to a new worksheet. You can then work on this 
new worksheet to add calculations and/or create graphs. 

In BehavePlus, only one variable can be plotted on a graph. A spreadsheet can be used 
to plot two variables on a graph. The BehavePlus run in Figure 53 examines the effect of 
changing the 1-h fuel load in fuel model 2 to values higher and lower than its value of 2 
tons/ac. A range of values from 0.5 to 5.0 ton/ac are used to calculate ROS and FL. For 
this example, we are not concerned with round off, so we developed a worksheet using 
the SURFACE input option Fuel is entered as Fuel parameters rather than opening the 
FuelModeling.bpw worksheet from the ExampleWorksheets folder (Sections 5.2 and 
10.1).
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(a)

(b)

Figure 53—Using the input in (a), a table and graphs (b) show the effect of a change in 1-h load 
for fuel model 2 on calculated surface rate of spread (c) and flame length (d).

Figure

(continued)
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(c)

(d)

Figure 53—Continued from previous page.
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File > Export results was used to save the table results in HTML format. The HTML 
file was opened with the spreadsheet program and saved as a spreadsheet file. The table 
output (a section of the complete HTML file) was then copied to another worksheet, and 
surface rate of spread and flame length were plotted on the same graph with the rate of 
spread axis on the left and the flame length axis on the right. A dashed line was added to 
show the initial fuel loading value (Figure 54). 

Figure 54—With a spreadsheet program, multiple variables can be plotted on the same graph. 
The inputs that create these data came from Figure 53a.

A spreadsheet can also be used to perform additional calculations. For this example, we 
calculate the ratio of surface rate of spread to flame length (Figure 55). This calculation 
was suggested for custom fuel model development by Burgan and Rothermel (1984) to 
deal with the common problem of generating approximately the right spread rate but having 
the flame length too low or vice versa. The plot shows whether spread rate will increase 
faster than flame length (rising curve) or slower (decreasing curve) as the value of the se-
lected parameter changes. (We converted the surface rate of spread from ch/h to ft/min in 
the spreadsheet although the unit conversion could have been done in BehavePlus before 
export.)

Figure 55—With a spreadsheet program, the ratio of surface rate of spread to flame length was 
calculated and plotted.
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9 File Management and Workspaces
File management and documentation are key components of any fire behavior prediction. 
You can use BehavePlus’ default file structure and create subfolders to organize your 
files. The use of workspaces, however, will help you keep track of your work and will aid 
in documenting and sharing results. BehavePlus workspaces store all BehavePlus files in 
a single, portable format. 

9.1 BehavePlus File Structure
BehavePlus has a prescribed file structure, and all BehavePlus files must be located in 
specific subdirectories (Figure 56). Because they are installed in different folders, Be-
havePlus, Version 5.0 and earlier versions of the program can be installed on your com-
puter at the same time. Some subfolders are created with program installation (Table 3). 
When files are saved, the appropriate BehavePlus folder is opened; new subfolders can 
then be created (Figure 57). Because exported HTML files and fuel models in FARSITE 
format are not used by BehavePlus, they can be saved anywhere on your computer.

Figure 56—The BehavePlus file 
structure is prescribed. BehavePlus, 
Versions 4.0 and 5.0 (as well as 
earlier versions) can be installed 
on the same computer. Subfolders 
can be created using File > Save 
as… (in this case, ExportFolders: 
FeaturesPaper and Workshop).



69USDA Forest Service Gen. Tech. Rep. RMRS-GTR-249. 2010

Table 3—BehavePlus folders produced when a new workspace is created (Section 9 .2) .

Folder name Subfolders at installation
Command to create subfold-
ers and save files

File ex-
tension

CaptureFolder MyScreenCaptures File > Save as an image .png
.jpg
.bmp

ComposerFolder Temporary files

ExportFolder MyExports File > Export results .html

FuelModelFolder MyFuelModels
SoCalifornia

File > Save as a fuel model > 
BehavePlus format

.bpf

MoistureScenarioFolder MyMoistureScenairos
FuelModeling
Tstmdl

File > Save as a moisture sce-
nario

.bpm

RunFolder MyRuns
ExampleRuns

File > Save as a run .bpr

UnitsSetFolder MyUnitsSets Configure > Custom units 
preferences

.bpu

WorksheetFolder MyWorksheets
ExampleWorksheets

File > Save as a worksheet .bpw

Figure 57—When a file is saved, the appropriate BehavePlus folder is accessed. New subfolders 
can be created for organization.
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9.2 Workspaces
The workspace feature allows users to build a custom configuration for an application 
such as a prescribed fire burn plan or a wildfire prediction. All the relevant information 
to recreate analyses performed is included in a single folder for documentation and file-
sharing.

The parent directory for the BehavePlus file structure and all its subdirectories and files 
is known collectively as a workspace. The DefaultDataFolder could have been named 
“DefaultWorkspace” because that is exactly what it is. The workspace includes all files in 
the parent directory, including any user-created folders and files. 

To create a new workspace, you can clone an existing workspace to obtain an identical 
version of the workspace under a new name (File > Workspaces > Clone current work-
space) that contains all files in that workspace (including any files you have created). 
Alternatively, to create a new workspace with the initial BehavePlus folders and files but 
with no user-created folders and files use the command File > Workspaces > New work-
space. 

Whether you clone a workspace or create a new workspace, it is always best to use the 
Make New Folder option (Figure 58). When naming your workspaces, we recommend 
using a folder name that indicates that a particular directory is a BehavePlus Workspace. 
For example, use the name BPWS_<FireName> or some equivalent naming scheme, 
where BPWS denotes that it is a BehavePlus WorkSpace. The name that you choose is 
equivalent to DefaultDataFolder in the default file structure.

Figure 58—Use the Make New Folder option when cloning a 
workspace or creating a new one.
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When you clone a workspace or create a new one, the location is given for confirma-
tion and you have the option of making the new workspace your current workspace. To 
change your current workspace, go to File > Workspaces > Open workspace and navi-
gate to the folder containing the workspace you wish to use. If you select a folder that is 
not a workspace, you will get a number of error messages. Each time you restart the pro-
gram, BehavePlus will start with the default workspace—the one that was created when 
the program was installed. Make sure you are using the correct workspace by checking 
the bottom bar of the BehavePlus window (Figure 2). 

10 Fuel Models
A fuel model is a set of numerical values that provides the fuel inputs for Rothermel’s 
(1972) mathematical model used to predict surface fire spread. When a fuel model code 
such as 10 or GS3 is specified, the appropriate set of fuel model parameters is defined for 
the calculations. The 53 standard fuel models (Anderson 1982; Scott and Burgan 2005) 
are available with BehavePlus, and you can create and use custom fuel models. While 
fuel models are generally used in modeling surface fire behavior, BehavePlus also of-
fers the option of specifying two fuel models along with their percent cover as a way to 
deal with horizontal fuel nonuniformity. As an alternative to using fuel model codes, fuel 
parameters can be entered. There are also special case fuel models for palmetto-gallberry 
and for western aspen, which include intermediate calculations to define the fuel input 
parameters (Figure 59). 

Figure 59—Options for specifying surface fuel for the SURFACE module are available on the Fuel 
& Moisture tab.
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10.1 Custom Fuel Models
Developing a custom fuel model is an exercise in modeling. It is not possible to directly 
use field data to define a custom fuel model. A person who is developing a custom fuel 
model should have a basic understanding of Rothermel’s model (Burgan 1987; Burgan 
and Rothermel 1984). The Intermediates tab of SURFACE includes fire model interme-
diate values such as relative packing ratio, heat source, heat sink, etc. (Figure 60).

Figure 60—Intermediate values help you understand the fire model for use in developing custom 
fuel models.

Once it has been determined that none of the standard 53 fuel models is appropriate, a 
common way to develop a custom fuel model is to make adjustments to an existing fuel 
model. Rather than selecting the option Fuel is entered as Fuel parameters (Figure 59), 
it is best to open the example worksheet FuelModeling.bpw or FuelModelingMetric.
bpw, both of which are designed with six decimal places for fuel load values to avoid 
possible issues with round off (Section 5.2). Click on the Initialize from a Fuel Model 
button on the worksheet and select one of the fuel models in the list to fill in values on the 
worksheet (Figure 61). Fuel model 1 (short grass) has only fine (1-h) dead fuel. A related 
custom fuel model might be developed by adding some live herbaceous fuel and reducing 
the 1-h load. Fuel modeling will involve producing tables and graphs to examine influ-
ence of changes on calculated surface rate of spread and flame length. It is also helpful to 
look at the intermediate values (Figure 60). 
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Figure 61—Using the FuelModeling.bpw worksheet, a click on Initialize from a Fuel Model fills 
in values (fuel load values contain six decimal places) from an existing fuel model to use as a 
starting point in developing a custom fuel model.

Once fuel parameters have been determined, the custom fuel model can be saved for later 
use in BehavePlus using File > Save as a fuel model > BehavePlus format. You can 
use the MyFuelModels folder or create one that will meet your needs. The entry in the 
Description line of the worksheet becomes the fuel model description. You can change it 
to a meaningful name for the fuel model before it is saved. BehavePlus fuel model files 
have the extension .bpf. 

Fuel models that have been saved for BehavePlus can also be exported in the format re-
quired by the FARSITE, FlamMap, and Nexus systems using File > Save as a fuel model 
> FARSITE format. These files will have the extension .fmd. The Help window gives 
guidance on naming conventions. You will probably want to save fuel models formatted 
for FARSITE somewhere other than in the BehavePlus folder to avoid confusion.

10.2 Selecting a Fuel Model
Clicking on the Guide button next to Fuel Model on the worksheet will bring up the fuel 
model Input Guide window. The 53 standard fuel models are always available (the origi-
nal 13 in Anderson 1982 and 40 more in Scott and Burgan 2005). Custom fuel models 
will appear at the end of the list during the session in which they are created. In future 
sessions, the custom fuel model folder must be attached using Configure > Fuel model 
set selection. Individual fuel model files are attached by selecting the folder in which 
they reside. It is not possible to select and attach individual fuel model files; the entire 
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folder must be attached. Once a folder is attached, the new fuel models appear in the se-
lection window. Several fuel model folders can be attached at one time.

A right-click on a fuel model in the selection window gives the option to View param-
eters (Figure 62). This is a quick way to check, for example, moisture of extinction or 
fuel bed depth of a fuel model. 

Figure 62—Right-click on a fuel model in the Input Guide list (a) to view its parameters (b).

(a)

(b)
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11 Moisture Scenarios
A fuel moisture scenario is a set of fuel moisture values that represent moisture condi-
tions of surface fuel: 1-h, 10-h, 100-h, live herbaceous, and live woody fuel moisture. 
Fuel moisture scenarios are analogous to fuel models—they package a number of val-
ues into a labeled set. The option of using moisture scenarios is available in SURFACE 
 Options… on the Fuel & Moisture tab (Figure 59). The moisture scenarios used by 
Scott and Burgan (2005) to develop the set of 40 fuel models are provided with the pro-
gram. Moisture scenario D2L1, for example, represents low dead, fully cured herbaceous 
fuel (1-h = 6%, 10-h = 7%, 100-h = 8%, live herbaceous = 30%, and live woody = 60%). 
Similar to fuel models, a right-click on a moisture scenario code in the selection list gives 
the option to View parameters. A window will open that shows the moisture values as-
sociated with each class of fuel (Figure 63).

Figure 63—Right-click the moisture scenario code in the selection list and select View parameters 
to view values of the moisture scenario.

11.1 Custom Moisture Scenarios
As a user, you can also define and save your own moisture scenarios. For example, you 
might want to define moisture values for the 90th and 97th percentile fire weather conditions 
for a prescribed fire site. To create a custom moisture scenario, use a BehavePlus work-
sheet that includes the SURFACE input option of Moisture is entered by individual size 
class. You need only to fill in the fuel moisture values on the worksheet and then click 
File > Save as a moisture scenario. When naming a custom moisture scenario, it is a 
good practice to include the values in the name for easy reference.
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11.2 Selecting Moisture Scenarios
As with fuel models, custom moisture scenarios are available during the session in which 
they were created. In future sessions, you must attach the folder in which they reside. It is 
not possible to select and attach individual moisture scenario files; the entire folder must 
be attached. 

Moisture scenarios are useful when developing custom fuel models. That option is se-
lected for the FuelModeling.bpw and FuelModelingMetric.bpw worksheets.

12 Table Shading for Acceptable Fire Conditions
A primary use of the BehavePlus option of Table shading for acceptable fire conditions 
is for prescribed fire planning. Acceptable conditions (such as 2- to 8-ft flame length) can 
be specified; unacceptable conditions are then “shaded” on output tables. (They are actu-
ally crossed off or left blank.) In this way, conditions such as wind speed and dead fuel 
moisture that result in acceptable conditions can be identified.

The approach used in BehavePlus is different from that in the RXWINDOW program 
of the old BEHAVE system (Andrews and Bradshaw 1990). RXWINDOW reversed the 
calculations to determine environmental conditions that corresponded to specified fire 
conditions. That approach is not feasible given the additional fire models (such as crown 
fire) that are available in BehavePlus.

To add acceptable fire conditions to your worksheet, check the box next to Table shading 
for acceptable fire conditions in the Module Selection window (Figure 1). Output vari-
ables available for table shading are given in a table in the BehavePlus Variables paper 
(Andrews 2009).

The added section of the worksheet lists output variables that allow input fields for mini-
mum and maximum acceptable values (Figure 64). Entered values only affect results if 
the associated box is checked. If acceptable conditions are specified for flame length, val-
ues outside of that range on the flame length output table are crossed off. Associated table 
entries are also crossed off on any other table that is produced (in this example, surface 
rate of spread and reaction intensity).

It is a good practice to first show the values that are crossed out (unacceptable values) so 
that you see what is happening. Once you create the table that you want, you can produce 
a nicely formatted table with blank cells using Configure > Appearance preferences > 
Tables, checking the box next to Show only acceptable conditions when table shading, 
and recalculating the run. 



77USDA Forest Service Gen. Tech. Rep. RMRS-GTR-249. 2010

(a)

Figure 64—Unacceptable conditions resulting from the inputs in (a) can be either crossed 
out (b) or left blank (c).

(continued)
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(c)

(b)

Figure 64—Continued from previous page.
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13 Tools
The BehavePlus fire modeling system provides a number of tools that are stand-alone 
utilities, meaning they are not linked with any of the calculation modules. They are avail-
able via Tools on the main menu (Figure 65). 
 • Fine dead fuel moisture is a means of reading values from moisture tables, which 

are in the Help window. Results can be exported in HTML format for documentation 
(Section 8.5).

 • Relative humidity provides a means for determining relative humidity from tables.
 • Units converter is a quick way to make conversions between related units of mea-

sure (Section 5.5).
 • Slope from map measurements calculates slope steepness in percent and degrees 

from map measurements. Results can be exported in HTML format for documenta-
tion. The tool provides the same outputs as the SURFACE module when the input 
option Slope steepness is calculated from map measurements is selected.

 • Slope vs horizontal map distance converts calculated map distances to horizontal 
map distances.

 • Sun-moon calendar allows you to generate sunrise, sunset, civil dawn and dusk, 
moonrise, and moonset in table or calendar format. The tool also displays a table of 
equinox, solstice, and moon phases for the year chosen.

Figure 65—Several stand-alone tools are available via the 
Tools drop-down menu on the toolbar. There is guidance for 
each tool in its Help window.

14 Map Applications
BehavePlus includes several features related to map applications. Calculated distances 
can be converted to map distances, distance along the ground can be converted to a hori-
zontal map distance, and slope steepness can be calculated from map measurements.

14.1 Map distances
The Module Selection window includes a check box to Display output distances in 
map units (Figure 1). This is a quick way to add map distance outputs from several mod-
ules with one click. Variables that are converted to map distances include surface spread 
distance in SPREAD; crown spread distance in CROWN; spotting distance in SPOT; and 
forward spread distance, backing spread distance, fire length, and maximum fire width in 
SIZE. 
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14.2 Slope versus Horizontal Map Distance
Map distance is found by multiplying slope distance by the map scale. This is not techni-
cally correct, but because of the many variables that exist in the real world, the difference 
between slope distance and horizontal distance is not critical. The Slope vs horizontal 
map distance tool (Figure 66) is provided to make a conversion of slope map distance 
to horizontal map distance in case you want to make the correction before you plot a dis-
tance on a map. (The tool requires slope input as a percentage and gives the associated 
value in degrees.)

Figure 66—The Slope vs horizontal map distance tool converts a calculated map distance on 
the slope to a horizontal distance given the maximum slope steepness and various directions with 
respect to upslope.

14.3 Slope from Map Measurements
Slope steepness can be directly entered into a SURFACE worksheet, or it can be calcu-
lated from map measurements by changing the input option on the Slope tab (Figure 67). 
The Slope Outputs tab lets you select the calculated slope and intermediate values as 
outputs. Because BehavePlus builds a worksheet that requests only required input values, 
you can build a simple slope calculation worksheet by selecting only the above input op-
tion and slope output variables (Figure 67). Conversely, you can use the Slope from map 
measurements tool if slope steepness is the only desired output (Section 14.5).
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(a)

(b)

Figure 67—An input option allows calculation of slope steepness from map measurements (a). 
Slope output variables are on a separate tab. The Help window explains the relationship of the 
values (b). These selections generate a simple slope calculation worksheet using SURFACE (c).

(continued)
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(c)

Figure 67—Continued from previous page.

14.4 Map Scale
When either Display output distances in map units or Slope steepness is calculated 
from map measurements is selected, the worksheet adds a section for Map input vari-
ables (Figure 67c). The Guide button for the map representative fraction offers a Choices 
button that provides several ways of specifying map scale (Figure 68).

Figure 68—The Choices button for map representative fraction gives map scale in several ways.
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14.5 Slope Tool
A stand-alone tool is available for quick calculations of slope steepness in percent and de-
grees from map measurements (Figure 69). It requests the same map measurements and 
provides the same outputs as the SURFACE module when the input option Slope steep-
ness is calculated from map measurements is selected.

Figure 69—The Slope from map measurements tool can be used to calculate slope steepness 
without creating a worksheet. The results can be exported in HTML format.
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15 Help
A variety of support material is available to users of the BehavePlus fire modeling sys-
tem. One of the lessons listed in Appendix B was developed to describe the help that is 
available, both within and beyond the BehavePlus program. This section presents a more 
general overview of help information sources.

A click on the Help button in the top menu bar (Figure 70) provides a link to information 
about the program: About BehavePlus, About Help, the User’s Guide, the Variables 
paper (Variable Help), an index of all components of the BehavePlus Help system in 
HTML format (Master Index), and Installation Info (Section 15.6).

Figure 70—The Help item on the toolbar provides access 
to several types of help.

15.1 User’s Guide
The User’s Guide (Andrews and others 2008) is a reference guide on program operation. 
It does not provide information on the fire models. The User’s Guide is a printable pub-
lication that is available as a PDF that comes with the program and can be opened with 
Help > User’s Guide. Bookmarks and internal links allow quick navigation to the area of 
interest. Updates to BehavePlus, Version 5.0 did not involve basic program operation, so 
the User’s Guide was not updated. The Version 4.0 User’s Guide is still valid.

15.2 Variables Paper
The Variables paper (Andrews 2009) describes the more than 180 variables in Behave-
Plus along with information on input and output relationships. As with the User’s Guide, 
it is available as a PDF that comes with the program (Help > Variable Help). The docu-
ment includes information that was previously available only in separate Help windows. 
The variables are organized in several ways to facilitate finding the required information. 
Bookmarks and links within the paper allow a user to navigate among related variables.
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15.3 Help Window
The right-hand pane of most BehavePlus windows contains information related to the 
subject of the window known as context-sensitive Help. The contents of any Help win-
dow can be printed with a right-click on the window.

The Guide button beside each variable on the worksheet opens a window for that vari-
able. The Help window gives a description of the variable, explaining how and where it 
is used. Some of these descriptions include pictures and diagrams while others include 
flowcharts. Additional information is available for many variables. For example, the 20-ft 
wind speed variable Help window provides an illustration and table of the Beaufort Scale 
for estimating 20-ft wind speed (Figure 71). In the CONTAIN module, the line resource 
production rate Help window contains tables from the Fireline Handbook, Appendix A 
(National Wildfire Coordinating Group 2004). 

In windows that list available output variables, hovering over a variable with the mouse 
will trigger a related Help window to appear (Figure 72). The Help window gives de-
scriptions of input options, including links to additional information in some cases 
( Figure 73).

Figure 71—The 20-ft wind speed variable Help window contains a table and illustration for 
estimating wind speed using the Beaufort Scale.
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Figure 72—Hovering over a given output variable (for example, flame length) in a list of output 
variables will trigger the related Help window to appear.

Figure 73—The Help window gives information on input options, including links to additional 
information.
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15.4 Master Index
The Master Index (Figure 74) provides direct access to all of the information found in 
the context-sensitive Help system. It can be accessed via Help on the toolbar (Figure 70) 
or by clicking the Index button at the top of all of the right-hand Help windows previ-
ously described. 
 • Variable Index accesses all input and output variables from an alphabetical list.
 • Figure Index gives a list of the figures contained in the Help system.
 • Table Index is a similar list of the tables in the Help system. 
 • Guide Index lists all other information available from the Help system (for ex-

ample, details on the two fuel model options, estimates of canopy bulk density, or a 
fuel model key for the original 13 standard models, as well as information regarding 
module input options, custom units, appearance preferences, and tools). 

 • Table of References lists models included in each BehavePlus module as well as rel-
evant citations.

These five selections are also provided at the bottom of every page in the Help system. 

You can navigate through the Help system using the Back, Frwd (Forward), Home, and 
Index buttons. The Home button will take you to the main Help window for the current 
section. For example, if an output page is showing, Home will take you to the Help file 
for Select Output Variables. If you are on an input options page, Home will take you 
to the Help file for that particular tab, regardless of how many times you have clicked 
through the Help system. If you are in the Master Index, the Home button will take you 
back to the Master Index. The Index button will return you to the Master Index, regard-
less of where you are in the program. 

Figure 74—The Master Index provides links to information about the variables, figures, tables, 
guides, and references included in the program’s HTML-based Help system.
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15.5 Web Site
Much more help is available on the BehavePlus web site. There are copies of publications 
on the mathematical models comprising BehavePlus and on related fire behavior topics 
(Figure 75) and training material (Appendix B), as well as a tips page and a change log. 

Figure 75—-The BehavePlus website contains copies of publications related to many aspects of 
fire behavior modeling, including those specific to models used in BehavePlus.
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Figure 76—Help > Installation Info opens a window with 
information about file locations, etc. Of most importance 
are the build number and the location of your startup 
worksheet.

15.6 Installation Information
Help on the main toolbar gives you access to Installation Info (Figure 70). The FYI 
window (Figure 76) that opens contains information about the BehavePlus setup that is 
organized according to categories.
 • Program Information gives the location of the executable file, the build number, 

and the date and time it was compiled. This information can help you determine if 
you have the latest version and build of the program. 

 • Directories gives file locations—the most important being the location of the current 
workspace and the location and name of the startup worksheet.

 • Environment Variables shows the current environment variable settings of the 
user’s computer. The $PATH environment variable, in particular, shows the order in 
which Microsoft Windows searches directories to find applications. This may be use-
ful in determining exactly which BehavePlus executable file is being run or why one 
version is being run in preference to another.

 • Display Metrics provides the resolution of your BehavePlus window on the desktop 
and the number of colors in use. This information can be changed by changing the 
desktop preferences of your Microsoft® Windows-based PC.

 • Image Files, Documentation Files, and Geographic Files sections will let you 
know if any of the relevant files are missing from your program. If there are no miss-
ing files, the text will read All [image, documentation, geographic location] files 
are present. Reinstalling the program will fix any problems that you may have.

 • Additional file information is available on files you have saved. You can find out 
about the fuel models, moisture scenarios, units sets, worksheet files, and run files 
in the current workspace. The window will tell you how many files you have created 
and where they are located.
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15.7 Technical Support
BehavePlus is a national system supported by U.S. Forest Service Fire and Aviation Man-
agement. The National Support Desk is available for software issues only and cannot deal 
with fire behavior questions. Contact information is available on the BehavePlus web site 
and in the Acknowledgments section of this report.

16 Program Updates
The BehavePlus program is occasionally updated as features and modeling capabilities 
are added to the program and as bugs are fixed. The BehavePlus web site provides the 
latest information. You can also subscribe to BehavePlus news on the web site to receive 
occasional e-mails regarding changes to BehavePlus. 

17 Summary
This paper was written to assist in using the BehavePlus fire modeling system and to sup-
plement the reference papers—the User’s Guide and the Variables paper. It is also a brief 
presentation of material found in the lessons on the BehavePlus web site.

This paper is not intended to teach professionals how to properly define inputs or inter-
pret output. Those tasks are left to courses, such as the S-390 course, and field experi-
ence. We hope that users (novice and advanced) will use this document to learn how to 
more effectively use BehavePlus to support their fire modeling tasks.

Basic BehavePlus design decisions were made over 10 years ago with the update from 
the DOS BEHAVE system to BehavePlus (Andrews and Bevins 1998). Some of the in-
ternal design features cannot be changed without a total system rebuild. Although there 
are features that we would design differently now, we feel that the BehavePlus system has 
been successful in many ways. We hope this document might help people design future 
generations of fire modeling software. 
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Appendix A. Tricks and Tips List
Following is a list of BehavePlus tips and tricks. These are discussed in more detail in the 
body of the paper (in each referenced section) or in the specified appendix. 

Worksheet Setup

 • Add additional Description lines to the worksheet header. (Section 3.1.3)

 • Change the size of or remove the Notes section. (Section 3.1.3)

 • Add tabs to the edge of BehavePlus pages to add space for additional documentation. 
(Section 3.1.2)

 • All selections are stored as part of a worksheet or run, including those not visible 
on the current worksheet. Selections include module selection; input options; output 
variables; appearance of graphs, tables, and worksheets; and units and decimal set-
tings. (Section 3 and Appendices D-H)

 • Use the worksheets designed explicitly for fuel modeling because the additional 
decimal display for fuel load reduces round off problems. (Section 3.3.1 and 5.2)

Enter Input

 • Enter values on a worksheet separated by commas, spaces, or any combination of 
commas and spaces. (Section 6.1)

 • Pick from a list of selected values for some continuous variables using the Choices 
button. (Section 6.4)

 • Check the range of valid values for a continuous variable using the Guide button. 
(Section 6.3)

 • Use the Guide button input fields to enter one value or two values (e.g., minimum 
and maximum plot values) as well as the more common three values (From, To, 
Step). (Section 6.3)

 • Look in the Help window for additional aid in determining input values. (Sections 
6.5 and 15.3)

Format Output

 • Enter a negative step size to format tables so that variables range from larger to 
smaller values (for example, fuel moisture). (Section 6.3)

 • Table shading of every other line of output tables can be removed or the color can be 
changed. (Section 7.2)

 • Using the option Table shading for acceptable conditions will create tables in 
which unacceptable values are crossed off or left blank. (Section 12)
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 • Graph appearance, including colors, size, and grid, can be changed. All of these se-
lections are saved with the worksheet or run. (Section 7.3.1)

 • Set the graph minimum values to either zero or the minimum calculated values. Let 
the Y-axis maximum be determined by the maximum calculated value or set the 
maximum value. (Section 7.3.3)

 • Change the order of input values on the worksheet to change the position of curve 
labels. (Section 7.3.1)

 • Decimal display of input variables on output tables is determined by the precision of 
values entered on the worksheet. (Section 5.1)

 • Change units and output decimal display for the current run without saving a custom 
units set. (Section 5.4)

View

 • Look at fuel model parameters or moisture scenario values by right-clicking on the 
selection in the Guide button window. (Section 10.2 and 11)

 • Use the View command to zoom in for presentations or zoom out to show the whole 
page. (Section 4.1)

 • Use the Pages command to jump directly to the page you want to view. (Section 4.3)

 • If you prefer not to see Dolack’s pictures in the left-hand window, you can turn them 
all off. That option will remain in effect for the next session. (Section 3.2.5)

 • Temporarily close the Dolack Picture pane to give more space to the Help window. 
(Section 3.2.5)

 • View multiple worksheets/runs at a time. (Section 4.2)

 • Scroll down to see if there is additional helpful information in the Help window. 
(Section 6.5 and 15.3)

 • Use the Master Index to look at tables, diagrams, variable description, etc., in the 
Help system. (Section 15.4)

Export and Print

 • Table results can be exported to an HTML file and opened with a browser. Long and 
wide tables are not split to fit on 8½- by 11-inch paper. (Section 8.5)

 • Open HTML files with spreadsheet software to do additional analysis and format-
ting. The file must be saved as a spreadsheet. (Section 8.6)
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 • Export moisture values calculated with the fine dead fuel moisture tool to an HTML 
file for documentation. (Section 13)

 • Print any Help window by right-clicking the window. (Section 15.3)

 • Capture a BehavePlus window with Alt-PrintScrn, insert it into a document, and 
crop it. (Section 8.4)

Personalization

 • Set the worksheet that opens when BehavePlus starts. (Section 3.3.3)

 • Example worksheets that come with the program have selections that we call 
 defaults. A user can define alternate sets of defaults for various applications. 
 (Section 3.3.2)

 • Use workspaces for documentation files and to share BehavePlus worksheets, runs, 
etc. (Section 9.2)
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Appendix B. BehavePlus Lessons List
BehavePlus self-study tutorials can be downloaded from the BehavePlus website. 
 Additional information about features described in this paper is available in the lessons.

Following are available or planned lessons at the time of this writing. 

Unit Lesson

Overview 1 - BehavePlus Overview

2 - BehavePlus Update

3 - Application of BehavePlus

4 - Before You Start with Fire Modeling

5 - Modeling Capabilities

6 - BehavePlus for Prescribed Fire

Introduction 1 - Basic Start

2 - Worksheets

3 - Input Methods

4 - Calculations

Operation 1 - Help, More Help, and Desperate for Help

2 - Features

3 - Worksheets (advanced)

4 - Independent vs . Linked Modules

5 - BehavePlus Results in Written Reports

6 - File Management

7 - Units and Decimals

8 - Table Shading 

9 - Export to Spreadsheet

Modeling 1 - Modeling Concepts

2 - Surface Fire Spread and Intensity

3 - Surface Fuel 

4 - Standard Fuel Models

5 - Custom Fuel Models

6 - Custom Fuel Models (advanced)

7 - Dynamic Fuel Models

8 - Two Fuel Models

9 - Special Case Fuel Model, Palmetto-Gallberry

10 - Special Case Fuel Model, Western Aspen

11 - Dead Fuel Moisture

12 - Live Fuel Moisture

13 - Moisture Scenarios

14 - Slope

15 - Wind

16 - Wind Adjustment Factor

17 - Directions

18 - Overstory Vegetation

19 - Crown Fire Spread

20 - Crown Fire Intensity

21 - Safety Zone Size

22 - Scorch and Mortality

23 - Spotting and Ignition

24 - Size

25 - Contain

26 - Map Applications
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Appendix C. Comparison of BehavePlus to Spatial 
Fire Behavior Systems
Comparison of BehavePlus and the spatial fire behavior systems: FlamMap, FARSITE, 
and FSPro (from Andrews 2007).

System Condition 
variation 
in time

Condition 
variation
in space

Duration 
specification

Input Modeling Output Computer 
access

BehavePlus
fire modeling 
system

Constant Uniform Elapsed 
time for size 
or spread 
distance

Interactive 
user input; 
generally 
ranges of 
values

Separate, 
independent 
calculation 
for each cell 
of a table or 
point on a 
graph

Tables, 
graphs, and 
simple dia-
grams

Personal 
computer

FlamMap
fire mapping 
and analysis 
system—

Basic fire 
behavior 
option

Constant Variable 
across the 
landscape

No time 
 duration in 
the modeling

Spatial (GIS) 
fuel and ter-
rain data

User-defined 
fuel mois-
ture, weather, 
and wind 

Separate, 
independent 
calculation 
for each point 
(pixel) on the 
landscape

Map of 
potential fire 
behavior for 
every point on 
the landscape

Personal 
computer

FlamMap 
fire mapping 
and analysis 
system—

Minimum 
travel time 
and fuel 
treatment 
optimization 
options 

Constant Variable 
across the 
landscape

Total burning 
time (min-
utes)

Spatial (GIS) 
fuel and ter-
rain data

User-defined 
fuel mois-
ture, weather, 
and wind 

Percentage of 
the landscape 
to treat and 
maximum 
treatment 
size

Minimum 
travel time 
based on 
numerous 
fire spread 
pathways

Map of 
minimum 
travel time 
pathways, and 
arrival time 
contours .

Fuel treatment 
placement 
recommenda-
tion

Personal 
computer

FARSITE 
fire area 
simulator

Vary diur-
nally and 
by day

Variable 
across the 
landscape

Hours/day 
of active 
burning

Number of 
days for the 
simulation

Spatial (GIS) 
fuel, terrain, 
etc ., data

User-defined 
fuel moisture, 
weather, and 
wind 

Fire growth 
simulation

Maps of fire 
growth,
perimeter, 
intensity, etc .

Personal 
computer

FSPro 
fire spread 
probabilities

Vary by 
day

Variable 
across the 
landscape

Hours/day of 
active burn-
ing by fire 
danger class

Number of 
days for the 
simulation

Spatial (GIS) 
fuel and ter-
rain data

Current fire 
perimeter

Weather 
stations for 
fire danger 
and wind 
climatology

Fuel moisture 
and wind se-
quences from 
climatology 

Hundreds or 
thousands of 
fire growth 
simulations

Map of prob-
ability of the 
fire reaching 
each point by 
the end of the 
simulation 
period 

“High end” 
comput-
ers with 
internet 
access by 
authorized 
analysts
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Appendix D. Input Options
Input options are specified in Configure > Module selection > Options… for each mod-
ule. All selections are saved with a worksheet or run. This table presents available input 
options and those selected for the 0Default.bpw and BasicStart.bpw worksheets.

Module Tab Input option 0Default.bpw and
BasicStart.bpw
selection

All input options

SURFACE Fuel & Moisture Fuel is entered as Fuel models (standard 
or custom) .

•	 Fuel models (standard or custom) .
•	 Fuel parameters (for custom fuel 

modeling) .
•	 Two fuel models, 2-dimensional 

expected spread (recommended) .
•	 Two fuel models, harmonic mean .
•	 Two fuel models, area weighted (like 

old BEHAVE) .
•	 Special case fuel model, palmetto-

gallberry (Hough and Albini 1978) .
•	 Special case fuel model, western aspen 

(Brown and Simmerman 1986) .

Dynamic curing 
load transfer is

calculated from live 
herbaceous fuel 
moisture .

•	 calculated from live herbaceous fuel 
moisture .

•	 input directly .

Moisture is 
entered by

individual size class . •	 individual class size .
•	 dead and live category .
•	 moisture scenario .

Wind Speed Wind speed is 
entered as

midflame height . •	 midflame height .
•	 20-ft wind and Input wind adjustment 

factor .
•	 20-ft wind and Calculated wind adjust-

ment factor .
•	 10-m wind and Input wind adjustment 

factor .
•	 10-m wind and Calculated wind 

adjustment factor .

Impose maximum 
reliable effective 
wind speed limit?

Yes •	 Yes
•	 No

Directions Surface fire 
spread direc-
tion is

only in the direction 
of maximum spread .

•	 only in the direction of maximum 
spread .

•	 in directions specified on the work-
sheet .

Wind is upslope . •	 specified on the worksheet .
•	 upslope .

Wind & spread 
directions are

degrees clockwise 
from upslope (direc-
tion the wind is push-
ing the fire) .

•	 degrees clockwise from upslope (di-
rection the wind is pushing the fire) .

•	 degrees clockwise from north (direc-
tion from which the wind is blowing) .

Slope Slope is speci-
fied as

percent . •	 percent .
•	 degrees .

Slope steepness is specified on the work-
sheet .

•	 specified on the worksheet .
•	 calculated from map measurements .

CROWN Input Options Surface fire inten-
sity is entered as

flame length . •	 flame length .
•	 fireline intensity .

CONTAIN Input Options Suppression input 
entered for

a single resource . •	 a single resource .
•	 multiple resources .

SCORCH Input Options Surface fire inten-
sity is entered as

flame length . •	 flame length .
•	 fireline intensity .
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Appendix E. Output Variables
Output variables are selected in Configure > Module selection > Options… for each 
module. All selections are saved with a worksheet or run. This table presents available 
output variables and those selected for the 0Default.bpw and BasicStart.bpw work-
sheets. 

Module Tab 0Default.bpw and
BasicStart.bpw
selections

All output options

SURFACE Basic Outputs •	 Surface Rate of Spread
•	 Flame Length

•	 Surface Rate of Spread
•	 Heat per Unit Area
•	 Fireline Intensity
•	 Flame Length
•	 Reaction Intensity
•	 Direction of Maximum Spread
•	 Surface Spread Distance
•	 Wind/Slope/Spread Direction Diagram
•	 Fire Characteristics Chart

Wind Outputs •	 None •	 Midflame Wind Speed
•	 Wind Adjustment Factor
•	 Crown Ratio
•	 Crown Fill Portion
•	 WAF Calculation
•	 Effective Wind Speed
•	 Effective Wind Speed Limit
•	 Max Eff Wind Exceeded?

Slope Outputs •	 None •	 Slope Steepness
•	 Slope Elevation Change
•	 Slope Horizontal Distance

Intermediates •	 None •	 Characteristic Dead Fuel Moisture
•	 Characteristic Live Fuel Moisture
•	 Live Fuel Moisture of Extinction
•	 Characteristic SA/V
•	 Bulk Density
•	 Packing Ratio
•	 Relative Packing Ratio
•	 Dead Fuel Reaction Intensity
•	 Live Fuel Reaction Intensity
•	 Wind Factor
•	 Slope Factor
•	 Heat Source
•	 Heat Sink
•	 Flame Residence Time

Fuel Outputs •	 None •	 Fuel Load Transfer Portion
•	 Dead Herbaceous Fuel Load
•	 Live Herb Fuel Load Remainder
•	 Total Dead Fuel Load
•	 Total Live Fuel Load
•	 Dead Fuel Load Portion
•	 Live Fuel Load Portion

Aspen Outputs •	 None •	 1-h Fuel Load
•	 Live Herbaceous Fuel Load
•	 Live Woody Fuel Load
•	 1-h SA/V
•	 Live Woody SA/V
•	 Probability of Aspen Mortality

P-G Outputs •	 None •	 P-G Dead Fine Fuel Load
•	 P-G Dead Medium Fuel Load
•	 P-G Dead Foliage Fuel Load
•	 P-G Live Fine Fuel Load
•	 P-G Live Medium Fuel Load
•	 P-G Live Foliage Fuel Load
•	 P-G Litter Fuel Load
•	 Fuel Bed Depth
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Module Tab 0Default.bpw and
BasicStart.bpw
selections

All output options

CROWN Spread Outputs •	 Critical Surface Intensity
•	 Transition Ratio
•	 Transition to Crown 

Fire?
•	 Crown ROS
•	 Critical Crown ROS
•	 Active Ratio
•	 Active Crown Fire?
•	 Fire Type

•	 Critical Surface Intensity
•	 Critical Surface Flame Length
•	 Transition Ratio
•	 Transition to Crown Fire?
•	 Crown ROS
•	 Critical Crown ROS
•	 Active Ratio
•	 Active Crown Fire?
•	 Fire Type
•	 Crown Spread Distance
•	 Crown Fire Area
•	 Crown Fire Perimeter
•	 Crown Fire Length-to-Width Ratio

Intensity Outputs •	 None •	 Crown Fireline Intensity
•	 Crown Flame Length
•	 Power of the Fire
•	 Power of the Wind
•	 Power Ratio
•	 Wind-driven Fire?
•	 Crown Load
•	 Canopy Heat per Unit Area
•	 Crown Fire Heat per Unit Area

SAFETY Output Variables •	 Safety Zone Separation 
Distance

•	 Safety Zone Size

•	 Safety Zone Separation Distance
•	 Safety Zone Size
•	 Safety Zone Radius

SIZE Output Variables •	 Area
•	 Perimeter 

•	 Area
•	 Perimeter
•	 Length-to-Width Ratio
•	 Forward Spread Distance
•	 Backing Spread Distance
•	 Fire Length
•	 Maximum Fire Width
•	 Fire Shape Diagram

CONTAIN Output Variables •	 Contain Status
•	 Time from Report
•	 Contained Area
•	 Fireline Constructed

•	 Fire Area at Initial Attack
•	 Perimeter at Initial Attack
•	 Contain Status
•	 Time from Report
•	 Contained Area
•	 Fireline Constructed
•	 Number of Resources Used
•	 Cost of Resources Used
•	 Containment Diagram
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Module Tab 0Default.bpw and
BasicStart.bpw
selections

All output options

SPOT Basic Outputs •	 Spotting Distance from 
Torching Trees

•	 Spotting Distance from Torching Trees
•	 Spotting Distance from a Burning Pile
•	 Spotting Distance from a Wind-Driven Surface 

Fire

Torching Tree 
Outputs

•	 None •	 Cover Ht Applied for Spotting Distance from 
Torching Trees

•	 Steady State Flame Ht from Torching Trees
•	 Tree Ht / Flame Ht Ratio for Torching Trees
•	 Steady State Flame Duration from Torching 

Trees
•	 Firebrand Ht from Torching Trees
•	 Flat Terrain Spotting Distance from Torching 

Trees

Burning Pile 
Outputs

•	 None •	 Cover Ht Applied for Spotting Distance from a 
Burning Pile

•	 Firebrand Ht from a Burning Pile
•	 Flat Terrain Spotting Distance from a Burning 

Pile

Surface Fire 
Outputs

•	 None •	 Cover Ht Applied for Spotting Distance from a 
Wind-Driven Surface Fire

•	 Firebrand Ht from a Wind-Driven Surface Fire
•	 Firebrand Drift Distance from a Wind-Driven 

Surface Fire
•	 Flat Terrain Spotting Distance from a Wind-

Driven Surface Fire

SCORCH Output Variables •	 Scorch Height •	 Scorch Height

MORTALITY Output Variables •	 Probability of Mortality •	 Bark Thickness
•	 Tree Crown Length Scorched
•	 Tree Crown Volume Scorched
•	 Probability of Mortality

IGNITE Output Variables •	 Probability of Ignition 
from a Firebrand

•	 Probability of Ignition from a Firebrand
•	 Probability of Ignition from Lightning
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Menu item 0Default.bpw and
BasicStart.bpw
selection

All menu item options

View •	 100% •	 50%
•	 67%
•	 75%
•	 83%
•	 100%
•	 117%
•	 133%
•	 150%
•	 167%
•	 200%

Configure Module selection •	 None (0Default .
bpw)

•	 SURFACE (Ba-
sicStart .bpw)

•	 SURFACE
•	 CROWN
•	 SAFETY
•	 SIZE
•	 CONTAIN
•	 SPOT
•	 SCORCH
•	 MORTALITY
•	 IGNITE

Fuel model set selection •	 None •	 Fuel model set selection must be made 
for every session if using saved custom 
fuel models .

•	 The 53 (13 + 40) standard fuel models 
are always available (Anderson 1982; 
Scott and Burgan 2005) .

Moisture scenario set 
selection

•	 None •	 Moisture scenario set selection must 
be made for every session if using saved 
custom moisture scenarios .

•	 The moisture scenarios used with the 40 
standard fuel models (Scott and Burgan 
2005) are always available .

Units set selection •	 English •	 English
•	 Metric
•	 Custom

Custom units preferences See Appendix G.

Appearance preferences See Appendix H.

Appendix F. Menu Items and Options
This table presents options available by choosing the menu items View and Configure. 
All options and those selected for the 0Default.bpw worksheet are given. BasicStart.
bpw also includes selection of the SURFACE module. All selections except the following 
are saved with a worksheet or run: View, Fuel model set selection, and Moisture sce-
nario set selection.
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Appendix G. Units and Decimals
Units of measure for all variables and the number of decimal places for output variables 
can be changed using Configure > Custom units preferences. (The number of decimal 
places displayed for input variables is determined by the variable of highest precision 
entered in the worksheet.) Changes can be saved as a custom units set and used again 
with Configure > Units set selection > Custom. Changes can also be applied to the open 
worksheet without saving a custom units set. Changes apply to all variables in a Units 
Category as given in this table. Settings for the default English and metric units and deci-
mal set are given. All selections are saved with a worksheet or run.

Units editor 
tab

Units category Variable English default Metric default

Units Output 
decimal 
places

Units Output 
decimal 
places

Fuel & 
Vegetation 
Units

Fuel Load •	 1-h Fuel Load
•	 Crown Load 
•	 Dead Herbaceous Fuel Load 
•	 Live Herbaceous Fuel Load 
•	 Live Herbaceous Fuel Load 

Remainder
•	 Live Woody Fuel Load 
•	 P-G Dead Fine Fuel Load 
•	 P-G Dead Foliage Fuel Load 
•	 P-G Dead Medium Fuel Load 
•	 P-G Litter Fuel Load
•	 P-G Live Fine Fuel Load
•	 P-G Live Foliage Fuel
•	 P-G Live Medium Fuel Load
•	 Total Dead Fuel Load
•	 Total Live Fuel Load

ton/ac 3 tonne/
ha

2

•	 10-h Fuel Load 
•	 100-h Fuel Load 

-- --

Surface Area/ Volume 
Ratio 

•	 1-h Surface Area/Volume Ratio 
•	 Characteristic Surface Area/ 

Volume Ratio
•	 Live Woody Surface Area/ 

Volume Ratio

ft2/ft3 0 m2/m3 0

•	 Live Herbaceous Fuel Surface 
Area/Volume Ratio

-- --

Surface Fuel Depth •	 Fuel Bed Depth ft 2 m 2

•	 P-G Height of Understory -- --

Ground Fuel Depth •	 Lightning Duff and Litter Depth in -- cm --

Fuel & Extinction 
Moisture

•	 Characteristic Dead Fuel 
 Moisture

•	 Characteristic Live Fuel Moisture 
•	 Live Fuel Moisture of Extinction 

percent 0 percent 0

•	 1-h Moisture 
•	 10-h Moisture 
•	 100-h Moisture 
•	 Dead Fuel Moisture
•	 Dead Fuel Moisture of Extinction
•	 Foliar Moisture 
•	 Live Fuel Moisture 
•	 Live Herbaceous Moisture 
•	 Live Woody Moisture 

-- --

Fuel Heat Content •	 Dead Fuel Heat Content
•	 Live Fuel Heat Content

Btu/lb -- kJ/kg --

Fuel Bulk Density •	 Bulk Density lb/ft3 4 kg/m3 4
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Units editor 
tab

Units category Variable English default Metric default

Units Output 
decimal 
places

Units Output 
decimal 
places

Fuel & 
Vegetation 
Units

Packing Ratio •	 Packing Ratio
•	 Relative Packing Ratio

ratio 4 ratio 4

Tree & Canopy 
Height 

•	 Tree Crown Length Scorched ft 0 m 0

•	 Canopy Base Height 
•	 Canopy Height
•	 Downwind Canopy Height
•	 Torching Tree Height 

-- --

Tree Dbh & Bark 
Thickness 

•	 Bark Thickness in 0 cm 0

•	 D .B .H . -- --

Canopy Bulk Density •	 Canopy Bulk Density lb/ft3 -- kg/m3 --

Coverage •	 Canopy Cover 
•	 First Fuel Model Coverage 
•	 P-G Palmetto Coverage

percent -- percent --

Basal Area •	 P-G Overstory Basal Area ft2/ac -- m2/ha --

Load & Crown Fill 
Portion

•	 Crown Fill Portion
•	 Dead Fuel Load Portion
•	 Fuel Load Transfer Portion
•	 Live Fuel Load Portion

percent 0 percent 0

•	 Aspen Curing Level -- --

Crown Ratio •	 Crown Ratio fraction 2 fraction 2

Weather 
Units

Wind Speed •	 Effective Wind Speed 
•	 Effective Wind Speed Limit
•	 Midflame Wind Speed 

mi/h 1 km/h 1

•	 10-m Wind Speed 
•	 20-ft Wind Speed 

-- --

Temperature •	 Air Temperature °F -- °C --

Shading from Sun •	 Fuel Shading from the Sun percent -- percent --

Wind Adjustment 
Factor 

•	 Wind Adjustment Factor fraction 2 fraction 2

Terrain & 
Spotting 
Units

Slope Steepness •	 Slope Steepness percent 0 percent 0

Slope & Elevation •	 Slope Elevation Change
•	 Slope Horizontal Distance

ft 0 m 0

•	 Ridge-to-Valley Elevation 
 Difference

-- --

Ridge-to-Valley 
 Horizontal Distance 

•	 Ridge-to-Valley Horizontal 
Distance

mi -- km --

Spotting Distance •	 Firebrand Drift from a Wind-
Driven Surface Fire 

•	 Flat Terrain Spotting Distance 
from a Burning Pile

•	 Flat Terrain Spotting Distance 
from a Wind-Driven Surface Fire

•	 Flat Terrain Spotting Distance 
from Torching Trees 

•	 Spotting Distance from a Burn-
ing Pile

•	 Spotting Distance from a Wind-
Driven Surface Fire

•	 Spotting Distance from Torching 
Trees

mi 1 km 1
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Units editor 
tab

Units category Variable English default Metric default

Units Output 
decimal 
places

Units Output 
decimal 
places

Terrain & 
Spotting 
Units

Firebrand & Cover 
Height

•	 Cover Height Applied for Spot-
ting Distance from a Burning Pile

•	 Cover Height Applied for Spot-
ting Distance from a Wind-Driv-
en Surface Fire

•	 Cover Height Applied for Spot-
ting Distance from Torching 
Trees

•	 Firebrand Height from a Burning 
Pile

•	 Firebrand Height from a Wind-
Driven Surface Fire

•	 Firebrand Height from Torching 
Trees

ft 1 m 1

Flame and Duration 
Ratios (can change 
decimal places only)

•	 Steady State Flame Duration 
from Torching Trees

no units 1 no units 1

•	 Tree Height / Flame Height Ratio 
for Torching Trees

ratio ratio

Fire & Effects 
Units

Surface Rate of 
Spread

•	 Surface Rate of Spread ch/h 1 m/min 1

Crown Rate of 
Spread 

•	 Critical Crown Rate of Spread
•	 Crown Rate of Spread

ch/h 1 m/min 1

Fire Heat Per Unit 
Area 

•	 Canopy Heat per Unit Area
•	 Crown Fire Heat per Unit Area
•	 Heat per Unit Area

Btu/ft2 0 kJ/m2 0

Fireline Intensity •	 Critical Surface Intensity
•	 Crown Fireline Intensity
•	 Fireline Intensity 

Btu/ft/s 0 kW/m 0

Flame Length & 
Scorch Height 

•	 Critical Surface Flame Length
•	 Crown Flame Length
•	 Flame Length
•	 Scorch Height
•	 Steady State Flame Height from 

Torching Trees

ft 1 m 1

•	 Flame Height from a Burning 
Pile

-- --

Heat Source & 
 Reaction Intensity 

•	 Dead Fuel Reaction Intensity
•	 Heat Source
•	 Live Fuel Reaction Intensity
•	 Reaction Intensity

Btu/ft2/
min

0 kW/m2 0

Heat Sink •	 Heat Sink Btu/ft3 1 kJ/m3 1

Spread Distance •	 Backing Spread Distance
•	 Crown Spread Distance 
•	 Fire Length
•	 Forward Spread Distance
•	 Maximum Fire Width
•	 Surface Spread Distance

ch 1 m 1

Fire Area •	 Area
•	 Contained Area 
•	 Crown Fire Area
•	 Fire Area at Initial Attack
•	 Fire Size at Report

ac 1 ha 1

Fire Perimeter •	 Crown Fire Perimeter
•	 Perimeter
•	 Perimeter at Initial Attack

ch 1 m 0
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Units editor 
tab

Units category Variable English default Metric default

Units Output 
decimal 
places

Units Output 
decimal 
places

Fire & Effects 
Units

Probability of 
 Mortality & Crown 
Volume Scorched 

•	 Probability of Aspen Mortality
•	 Probability of Mortality
•	 Tree Crown Volume Scorched 

percent 0 percent 0

Probability of 
 Ignition 

•	 Probability of Ignition from a 
Firebrand 

•	 Probability of Ignition from 
Lightning

percent 0 percent 0

Fire Ratios •	 Active Ratio
•	 Crown Fire Length-to-Width 

Ratio
•	 Length-to-Width Ratio
•	 Power Ratio
•	 Transition Ratio

ratio 1 ratio 1

Wind, Slope Factor, 
& Cost 

•	 Cost of Resources Used 
•	 Slope Factor
•	 Wind Factor

ratio 1 ratio 1

•	 Resource Base Cost
•	 Resource Hourly Cost

no units -- no units --

Power •	 Power of the Fire
•	 Power of the Wind

ft-lb/s/
ft2

0 m-kg/s/
m2

0

Time & 
Map Units

Time •	 Time from Report h 1 h 1

•	 Elapsed Time 
•	 Resource Arrival Time
•	 Resource Duration

-- --

Flame Residence 
Time

•	 Flame Residence Time min 2 min 2

P-G Age of Rough •	 P-G Age of Rough years -- years --

Contour Interval •	 Contour Interval ft -- m --

Map Distance •	 Backing Spread Map Distance 
•	 Crown Fire Spread Map Distance 
•	 Fire Length Map Distance 
•	 Forward Spread Map Distance 
•	 Maximum Fire Width Map 

Distance 
•	 Ridge-to-Valley Horizontal Map 

Distance 
•	 Spotting Map Distance from a 

Burning Pile 
•	 Spotting Map Distance from a 

Wind-Driven Surface Fire 
•	 Spotting Map Distance from 

Torching Trees 
•	 Spread Map Distance

in 2 cm 2

•	 Map Distance (for slope 
 calculation)

-- --

Contain & 
Safety Units

Line Production Rate •	 Resource Line Production Rate ch/h -- m/h --

Containment 
 Distances 

•	 Fireline Constructed ch 0 m 0

•	 Line Construction Offset -- --

Safety Zone 
 Distances 

•	 Safety Zone Radius 
•	 Safety Zone Separation Distance

ft 0 m 0

Safety Zone Size •	 Safety Zone Size ac 2 ha 0

Personnel & 
 Equipment Areas 

•	 Area per Heavy Equipment
•	 Area per Person

ft2 -- m2 --
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Appearance 
preferences
tab

Option 0Default.bpw and
BasicStart.bpw
selection

All appearance preference tab options

Application Show help pane •	 Selected •	 Cleared
•	 Selected

Show picture pane •	 Selected •	 Cleared
•	 Selected

Border Color •	 Black •	 White
•	 Black
•	 Grey
•	 Red
•	 Green
•	 Blue
•	 Magenta
•	 Cyan
•	 Yellow
•	 Dark Red
•	 Dark Green
•	 Dark Blue
•	 Dark Magenta
•	 Dark Cyan
•	 Dark Yellow

Border Width •	 1 •	 0 = No border
•	 1-9 = Increasingly thicker border

Graph Size Graph Size (%) •	 50% •	 25 – 100% by 5% increment

Graph Title •	 Short •	 Short
•	 Long

X Axis Origin •	 Zero •	 Zero
•	 Min Value

Y Axis Origin •	 Zero •	 Zero
•	 Min Value

Graph Elements Background •	 White •	 See Application > Border Color

Rainbow Colors •	 3 •	 3-18

Bar Color •	 Red •	 See Application > Border Color
•	 Rainbow Colors

Curve Points •	 100 •	 4-100

Curve Color •	 Rainbow Colors •	 See Application > Border Color
•	 Rainbow Colors

Curve Width •	 3 •	 0 = No curve line
•	 1-9 = Increasingly thicker curve line

Axis Color •	 Black •	 See Application > Border Color

Axis Width •	 1 •	 1-9 = Increasingly thicker axis

Gridline Color •	 Yellow •	 See Application > Border Color

Gridline Width •	 1 •	 0 = No gridline
•	 1-9 = Increasingly thicker gridline

Appendix H. Appearance Preferences
Appearance of the BehavePlus window, worksheets, tables, and graphs can be changed 
with Configure > Appearance preferences. This table presents all available options and 
those selected for the 0Default.bpw and BasicStart.bpw worksheets. Selections on the 
Application tab remain in effect for the next BehavePlus session. All other selections are 
saved with a worksheet or run.



108 USDA Forest Service Gen. Tech. Rep. RMRS-GTR-249. 2010

Appearance 
preferences
tab

Option 0Default.bpw and
BasicStart.bpw
selection

All appearance preference tab options

Page Tabs Display the page tab •	 Cleared •	 Cleared
•	 Selected

Tabs per Page •	 4 •	 0 = No tabs
•	 1-10 = number of tabs per page

Tab Position •	 0 •	 0 = No tabs
•	 1-4; position 1 is always the upper 

edge of the right margin

Tab Text •	 Blank •	 Blank
•	 User defined

Tab Text Color •	 Black •	 See Application > Border Color

Tab Font Size •	 12 •	 8-24

Tables Shade alternate table rows •	 Selected •	 Cleared
•	 Selected

Shade •	 Light Grey •	 Light Grey
•	 Light Pink
•	 Light Green
•	 Light Blue
•	 Light Cyan
•	 Light Yellow
•	 Light Goldenrod
•	 Light Coral
•	 Light Salmon
•	 Light Slate Grey
•	 Light Slate Blue
•	 Light Sky Blue
•	 Light Steel Blue
•	 Light Sea Green

Show only acceptable conditions 
when table shading

•	 Cleared •	 Cleared
•	 Selected

Worksheet Prescribed fire plan worksheet header •	 Cleared •	 Cleared
•	 Selected

Fire behavior projection worksheet 
header

•	 Cleared •	 Cleared
•	 Selected

Training worksheet header •	 Cleared •	 Cleared
•	 Selected

Show descriptions for all discrete 
 variable codes

•	 Cleared •	 Cleared
•	 Selected

Show descriptions only for entered 
discrete variable codes

•	 Selected •	 Cleared
•	 Selected

Show output variables to be calcu-
lated

•	 Selected •	 Cleared
•	 Selected

Show notes section •	 Selected •	 Cleared
•	 Selected

Notes Lines •	 4 •	 1-10
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Appendix I. Glossary
Definition of terms in the context in which they are used in this report.

1-h, 10-h, 100-h—Dead fuel size classes based on a relationship of the timelag from a 
change in weather and a resulting change in fuel moisture. 1-h timelag fuels are less than 
¼ inch diameter and respond quickly to changes in temperature and humidity.

BehavePlus—The BehavePlus fire modeling system produces tables, graphs, and simple 
diagrams of fire behavior, fire effects, and the fire environment. It is a point-based sys-
tem; each individual calculation assumes constant conditions. (Appendix C)

BEHAVE—The BEHAVE fire behavior prediction and fuel modeling system consisted 
of five computer programs and has been replaced by the BehavePlus fire modeling sys-
tem. (Preface)

Build number—Build number changes with each program update. The version number 
stays the same for beta versions while the build number changes (Build 297). It is located 
via Help > Installation Info. (Section 15.6)

Calculate—Menu item or icon that produces output pages for a BehavePlus run. 
 (Section 3)

Choices—A button at the bottom of the guide window for some continuous variables that 
gives a list of selected input values. It is not an exhaustive list of all possible inputs. (Sec-
tion 6.4)

Context-sensitive Help—Located in the right-hand pane of many BehavePlus windows; 
contains information related to the current variable, selection, or topic. (Section 15.3)
 
Continuous variable—Any value in a valid range can be assigned to a continuous vari-
able (for example, fuel moisture and wind speed). (Section 6)

Defaults—Selections that were made for the example worksheets that come with the pro-
gram (including 0Default.bpw). A user can develop an alternate set of defaults. (Section 
3.3.2)

Discrete variable—Only specific values or codes can be assigned to discrete variables 
(for example, fuel model and spotting source location). (Section 6)

FARSITE—A fire growth simulation system in which conditions change in both time 
and space. (Appendix C)

Features paper—This publication is the Features paper. It describes many of the features 
of BehavePlus. The focus is on operation, not fire modeling. 

File extension—BehavePlus uses different file extensions for various file types: fuel 
models as .bpf, worksheets as .bpw, runs as .bpr, etc. (Section 9.1)
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File structure—BehavePlus has a prescribed file structure that is installed with the pro-
gram (for example, FuelModelFolder and RunFolder). (Section 9.1)

FlamMap—A spatial fire behavior system, in which basic operation conditions are con-
stant in time and vary in space. (Appendix C)

Fuel model—A code such as 2 or GR2 is entered to assign a set of values that describe 
the fuels (for example, fuel load and fuel bed depth) for the surface fire spread model in 
the SURFACE module. (Section 10) 

Guide button—A blue Guide button that contains an arrow is associated with each input 
variable on the worksheet. It opens a window with guidance on input values in the center 
pane and help information in the right-hand pane. (Section 3.1.3) 

Help window—The right-hand pane of most BehavePlus windows that contains informa-
tion related to the subject of the window. (Section 15.3)

Icon—Icons on a toolbar at the top of the BehavePlus window are for commonly used 
commands (for example, Module Selection, Calculate, and page navigation). (Section 
3.1.1) 

Input options—Options that define input methods (such as the option to input or to 
 calculate wind adjustment factor). Selection is made on the window that opens from the 
Options… button associated with a module. (Section 3.2.3; Appendix D)

Map distance—A check mark in the Module Selection window adds map distance out-
puts for selected distance output variables (for example, surface spread distance and spot-
ting distance). Map distance is the calculated distance times the map scale. (Section 14.1)

Menu—The menu items located in the toolbar at the top of the BehavePlus window pro-
vide access to all BehavePlus commands. (Section 3.1.1)

Model—Mathematical relationships that describe an aspect of wildland fire (for example, 
flame length and scorch height). (Section 2) 

Module—A logical grouping of models in BehavePlus (for example, SURFACE, SIZE, 
and CROWN). (Section 2)

Moisture scenario—A code such as D2L3 is entered to assign a set of fuel moisture val-
ues (1-h, 10-h, 100-h, live herbaceous, and live woody) for the surface fire spread model 
in the SURFACE module. (Section 11)

Native units—The units of the publication that describes a mathematical model. Behave-
Plus calculations are done in the native units, regardless of the units selected for input and 
output variables. Internal conversions can lead to differences due to round off. (Section 5)

Run—A BehavePlus worksheet in which values have been assigned to the required input 
categories. A run file includes not only what is visible, but an entire suite of selections, 
including selections made on table and graph output. (Section 3; Appendices D-H).
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Session—A period of time a person is running BehavePlus, from the time the pro-
gram is started until it is closed. Selections on the Configure > Appearance preferences 
> Application tab are carried over from one session to another (Help and Picture pane 
display and border color and width). (Section 3.2)

Slope distance—Map distance is the distance along the slope, on the ground. A Behave-
Plus tool makes the conversion to a horizontal map distance. (Section 14.2)

System—A computer program or some other packaging of models, interface, and data 
into a form that fire managers can use (for example, nomograms, BehavePlus, FARSITE, 
and FlamMap). (Section 2)

Tool—BehavePlus tools are stand-alone calculations and are available from the main 
menu (for example, fine dead fuel moisture and relative humidity). (Section 13)

User’s Guide—A reference guide that describes the operation of BehavePlus. It is avail-
able in the program from Help > User’s Guide. Basic operation was not changed with 
the update to Version 5.0; the Version 4.0 User’s Guide is still valid. (Section 15.1; An-
drews and others 2008)

Variables paper—A reference guide that describes the more than 180 variables in Be-
havePlus. It is available in the program from Help > Variable Help. (Section 15.2; An-
drews 2009)

Version number—Program version number (5.0.1) appears at the top of every Behave-
Plus page. (Section 15.6)

Worksheet—A form that guides user input to BehavePlus. It is created based on user se-
lection of modules, input options, and output variables. Only required input values are in-
cluded on the worksheet. A worksheet file includes not only what is visible, but an entire 
suite of selections. (Section 3; Appendices D-H)

Workspace—Parent directory of the BehavePlus file structure and all its subdirectories 
and files (DefaultDataFolder or a user-defined folder). Workspaces are useful for docu-
mentation and for sharing BehavePlus files. (Section 9.2)
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